blob: 7b4d138d2c5aa2ff63853d708adb7593f09d349a [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "WebP is an image format designed for the Web"
2DESCRIPTION = "WebP is a method of lossy and lossless compression that can be \
3 used on a large variety of photographic, translucent and \
4 graphical images found on the web. The degree of lossy \
5 compression is adjustable so a user can choose the trade-off \
6 between file size and image quality. WebP typically achieves \
7 an average of 30% more compression than JPEG and JPEG 2000, \
8 without loss of image quality."
9HOMEPAGE = "https://developers.google.com/speed/webp/"
10SECTION = "libs"
11
12LICENSE = "BSD-3-Clause"
13LIC_FILES_CHKSUM = "file://COPYING;md5=6e8dee932c26f2dab503abf70c96d8bb \
14 file://PATENTS;md5=c6926d0cb07d296f886ab6e0cc5a85b7"
15
16SRC_URI = "http://downloads.webmproject.org/releases/webp/${BP}.tar.gz"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060017SRC_URI[sha256sum] = "64ac4614db292ae8c5aa26de0295bf1623dbb3985054cb656c55e67431def17c"
Patrick Williams92b42cb2022-09-03 06:53:57 -050018
19UPSTREAM_CHECK_URI = "http://downloads.webmproject.org/releases/webp/index.html"
20
21EXTRA_OECONF = " \
22 --disable-wic \
23 --enable-libwebpmux \
24 --enable-libwebpdemux \
25 --enable-threading \
26"
27
28# Do not trust configure to determine if neon is available.
29#
30EXTRA_OECONF_ARM = " \
31 ${@bb.utils.contains("TUNE_FEATURES","neon","--enable-neon","--disable-neon",d)} \
32"
33EXTRA_OECONF:append:arm = " ${EXTRA_OECONF_ARM}"
34EXTRA_OECONF:append:armeb = " ${EXTRA_OECONF_ARM}"
35
36inherit autotools lib_package
37
38PACKAGECONFIG ??= ""
39
40# libwebpdecoder is a subset of libwebp, don't build it unless requested
41PACKAGECONFIG[decoder] = "--enable-libwebpdecoder,--disable-libwebpdecoder"
42
43# Apply for examples programs: cwebp and dwebp
44PACKAGECONFIG[gif] = "--enable-gif,--disable-gif,giflib"
45PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
46PACKAGECONFIG[png] = "--enable-png,--disable-png,,libpng"
47PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff"
48
49# Apply only for example program vwebp
50PACKAGECONFIG[gl] = "--enable-gl,--disable-gl,mesa-glut"
51
52PACKAGES =+ "${PN}-gif2webp"
53
54DESCRIPTION:${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP"
55FILES:${PN}-gif2webp = "${bindir}/gif2webp"