Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "A library for text mode user interfaces" |
| 2 | |
| 3 | DESCRIPTION = "Newt is a programming library for color text mode, widget based user \ |
| 4 | interfaces. Newt can be used to add stacked windows, entry widgets, \ |
| 5 | checkboxes, radio buttons, labels, plain text fields, scrollbars, \ |
| 6 | etc., to text mode user interfaces. This package also contains the \ |
| 7 | shared library needed by programs built with newt, as well as a \ |
| 8 | /usr/bin/dialog replacement called whiptail. Newt is based on the \ |
| 9 | slang library." |
| 10 | |
| 11 | HOMEPAGE = "https://releases.pagure.org/newt/" |
| 12 | SECTION = "libs" |
| 13 | |
| 14 | LICENSE = "LGPLv2" |
| 15 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 16 | |
| 17 | # slang needs to be >= 2.2 |
| 18 | DEPENDS = "slang popt" |
| 19 | |
| 20 | SRC_URI = "https://releases.pagure.org/newt/newt-${PV}.tar.gz \ |
| 21 | file://fix_SHAREDDIR.patch \ |
| 22 | file://cross_ar.patch \ |
| 23 | file://Makefile.in-Add-tinfo-library-to-the-linking-librari.patch \ |
| 24 | file://pie-flags.patch \ |
| 25 | file://0001-detect-gold-as-GNU-linker-too.patch \ |
| 26 | " |
| 27 | |
| 28 | SRC_URI[md5sum] = "70b288f821234593a8e7920e435b259b" |
| 29 | SRC_URI[sha256sum] = "8d66ba6beffc3f786d4ccfee9d2b43d93484680ef8db9397a4fb70b5adbb6dbc" |
| 30 | |
| 31 | S = "${WORKDIR}/newt-${PV}" |
| 32 | |
| 33 | EXTRA_OECONF = "--without-tcl --without-python" |
| 34 | |
| 35 | inherit autotools-brokensep |
| 36 | |
| 37 | CLEANBROKEN = "1" |
| 38 | |
| 39 | export CPPFLAGS |
| 40 | |
| 41 | PACKAGES_prepend = "whiptail " |
| 42 | |
| 43 | do_configure_prepend() { |
| 44 | sh autogen.sh |
| 45 | } |
| 46 | |
| 47 | do_compile_prepend() { |
| 48 | # Make sure the recompile is OK |
| 49 | rm -f ${B}/.depend |
| 50 | } |
| 51 | |
| 52 | FILES_whiptail = "${bindir}/whiptail" |
| 53 | |
| 54 | BBCLASSEXTEND = "native" |