blob: 50a5ae0850767a8a4eccad730af916de4c83a959 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Hardware accelerated JPEG compression/decompression library"
2DESCRIPTION = "libjpeg-turbo is a derivative of libjpeg that uses SIMD instructions (MMX, SSE2, NEON) to accelerate baseline JPEG compression and decompression"
3HOMEPAGE = "http://libjpeg-turbo.org/"
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://cdjpeg.h;endline=13;md5=8184bcc7c4ac7b9edc6a7bc00f231d0b \
7 file://jpeglib.h;endline=16;md5=f67d70e547a2662c079781c72f877f72 \
8 file://djpeg.c;endline=11;md5=c59e19811c006cb38f82d6477134d314 \
9"
10DEPENDS_append_x86-64_class-target = " nasm-native"
11DEPENDS_append_x86_class-target = " nasm-native"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "7c82f0f6a3130ec06b8a4d0b321cbca3"
16SRC_URI[sha256sum] = "b24890e2bb46e12e72a79f7e965f409f4e16466d00e1dd15d93d73ee6b592523"
17UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/libjpeg-turbo/files/"
18UPSTREAM_CHECK_REGEX = "/libjpeg-turbo/files/(?P<pver>(\d+[\.\-_]*)+)/"
19
20PE= "1"
21
22# Drop-in replacement for jpeg
23PROVIDES = "jpeg"
24RPROVIDES_${PN} += "jpeg"
25RREPLACES_${PN} += "jpeg"
26RCONFLICTS_${PN} += "jpeg"
27
28inherit autotools pkgconfig
29
30# Add nasm-native dependency consistently for all build arches is hard
31EXTRA_OECONF_append_class-native = " --without-simd"
32
33# Work around missing x32 ABI support
34EXTRA_OECONF_append_class-target = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", "--without-simd", "", d)}"
35
36# Work around missing non-floating point ABI support in MIPS
37EXTRA_OECONF_append_class-target = " ${@bb.utils.contains("MIPSPKGSFX_FPU", "-nf", "--without-simd", "", d)}"
38
39# Provide a workaround if Altivec unit is not present in PPC
40EXTRA_OECONF_append_class-target_powerpc = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "", "--without-simd", d)}"
41EXTRA_OECONF_append_class-target_powerpc64 = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "", "--without-simd", d)}"
42
43def get_build_time(d):
44 if d.getVar('SOURCE_DATE_EPOCH') != None:
45 import datetime
46 return " --with-build-date="+ datetime.datetime.fromtimestamp(float(d.getVar('SOURCE_DATE_EPOCH'))).strftime("%Y%m%d")
47 return ""
48
49EXTRA_OECONF_append_class-target = "${@get_build_time(d)}"
50
51PACKAGES =+ "jpeg-tools libturbojpeg"
52
53DESCRIPTION_jpeg-tools = "The jpeg-tools package includes client programs to access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files and benchmarking of the libjpeg library."
54FILES_jpeg-tools = "${bindir}/*"
55
56DESCRIPTION_libturbojpeg = "A SIMD-accelerated JPEG codec which provides only TurboJPEG APIs"
57FILES_libturbojpeg = "${libdir}/libturbojpeg.so.*"
58
59BBCLASSEXTEND = "native"