Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | SUMMARY = "Ultra-simple screen capture utility, aimed at handheld devices" |
| 2 | HOMEPAGE = "http://www.o-hand.com" |
| 3 | BUGTRACKER = "http://bugzilla.yoctoproject.org/" |
| 4 | |
| 5 | LICENSE = "GPLv2 & GPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 7 | file://main.c;endline=9;md5=023e14d6404d0a961eb97cbd011fc141 \ |
| 8 | file://screenshot-ui.h;endline=9;md5=638d9ffa83e9325a36df224166ed6ad0" |
| 9 | |
| 10 | DEPENDS = "matchbox-panel-2 gtk+3" |
| 11 | |
| 12 | # SRCREV tagged 0.3 |
| 13 | SRCREV = "9250fa5a012d84ff45984e8c4345ee7635227756" |
| 14 | SRC_URI = "git://git.yoctoproject.org/screenshot" |
| 15 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | inherit autotools pkgconfig distro_features_check |
| 20 | |
| 21 | FILES_${PN} += "${libdir}/matchbox-panel/*.so" |
| 22 | |
| 23 | do_install_append () { |
| 24 | rm ${D}${libdir}/matchbox-panel/*.la |
| 25 | } |
| 26 | |
| 27 | # The matchbox-panel-2 requires x11 in DISTRO_FEATURES |
| 28 | REQUIRED_DISTRO_FEATURES = "x11" |