Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | SUMMARY = "Simple GTK+ based panel for handheld devices" |
| 2 | HOMEPAGE = "http://matchbox-project.org" |
| 3 | BUGTRACKER = "http://bugzilla.yoctoproject.org/" |
| 4 | |
| 5 | LICENSE = "GPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 7 | file://matchbox-panel/mb-panel.h;endline=10;md5=0b7db28f4b6863fb853d0467e590019a \ |
| 8 | file://applets/startup/startup.c;endline=22;md5=7cbcea60b667f609495222faf3e07917" |
| 9 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 10 | DEPENDS = "gtk+3 startup-notification dbus dbus-glib dbus-glib-native" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 11 | DEPENDS += " ${@bb.utils.contains("MACHINE_FEATURES", "acpi", "libacpi", "",d)}" |
| 12 | DEPENDS += " ${@bb.utils.contains("MACHINE_FEATURES", "apm", "apmd", "",d)}" |
| 13 | |
| 14 | # The startup-notification requires x11 in DISTRO_FEATURES |
| 15 | REQUIRED_DISTRO_FEATURES = "x11" |
| 16 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 17 | # SRCREV tagged 2.11 plus some autotools fixes |
| 18 | SRCREV = "f82ca3f42510fb3ef10f598b393eb373a2c34ca7" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 19 | |
| 20 | RPROVIDES_${PN} = "matchbox-panel" |
| 21 | RREPLACES_${PN} = "matchbox-panel" |
| 22 | RCONFLICTS_${PN} = "matchbox-panel" |
| 23 | |
| 24 | SRC_URI = "git://git.yoctoproject.org/${BPN} \ |
| 25 | file://0001-applets-systray-Allow-icons-to-be-smaller.patch \ |
| 26 | " |
| 27 | |
| 28 | EXTRA_OECONF = "--enable-startup-notification --enable-dbus" |
| 29 | EXTRA_OECONF += " ${@bb.utils.contains("MACHINE_FEATURES", "acpi", "--with-battery=acpi", "",d)}" |
| 30 | EXTRA_OECONF += " ${@bb.utils.contains("MACHINE_FEATURES", "apm", "--with-battery=apm", "",d)}" |
| 31 | |
| 32 | S = "${WORKDIR}/git" |
| 33 | |
| 34 | FILES_${PN} += "${libdir}/matchbox-panel/*.so \ |
| 35 | ${datadir}/matchbox-panel/brightness/*.png \ |
| 36 | ${datadir}/matchbox-panel/startup/*.png \ |
| 37 | ${datadir}/icons/" |
| 38 | FILES_${PN}-dev += "${libdir}/matchbox-panel/*.la" |
| 39 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 40 | inherit autotools pkgconfig features_check gettext |