blob: 4fbd4b1f6a33a5bdaee88b399d33f7a8b533fb5a [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001# Copyright (C) 2018 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "NSS module for glibc, to provide NIS support for glibc"
5
6DESCRIPTION = "This package contains the NSS NIS plugin for glibc.\
7This code was formerly part of glibc, but is now standalone to\
8be able to link against TI-RPC for IPv6 support."
9
10HOMEPAGE = "https://github.com/thkukuk/libnss_nis"
11LICENSE = "LGPL-2.1"
12LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
13SECTION = "libs"
14DEPENDS += "libtirpc libnsl2"
15
16PV = "3.0+git${SRCPV}"
17
18SRCREV = "d4aea48657a8e90d7922574b8021ee03915a36cb"
19
20SRC_URI = "git://github.com/thkukuk/libnss_nis \
Brad Bishop08902b02019-08-20 09:16:51 -040021 file://0001-nis-hosts-Remove-use-of-RES_USE_INET6.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022 "
23
24S = "${WORKDIR}/git"
25
26inherit autotools pkgconfig
27
28BBCLASSEXTEND += "native nativesdk"
29#
30# We will skip parsing this packagegeoup for non-glibc systems
31#
32COMPATIBLE_HOST_libc-musl = 'null'