blob: 7d194b305e15784678e03de970d8aba98d5e6da6 [file] [log] [blame]
Brad Bishop08902b02019-08-20 09:16:51 -04001SUMMARY = "System load testing utility"
2DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
3imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
4HOMEPAGE = "https://kernel.ubuntu.com/~cking/stress-ng/"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
9 file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \
10 file://0001-bash-completion-remove-the-shebang-at-the-start.patch \
11 "
12SRC_URI[md5sum] = "46aa41d37690324ceab4febfcc549018"
13SRC_URI[sha256sum] = "d09dd2a1aea549e478995bf9be90b38906a4cdf33ea7b245ef9d46aa5213c074"
14
15DEPENDS = "coreutils-native"
16
Brad Bishopc68388fc2019-08-26 01:33:31 -040017PROVIDES = "stress"
18RPROVIDES_${PN} = "stress"
19RREPLACES_${PN} = "stress"
20RCONFLICTS_${PN} = "stress"
21
Brad Bishop08902b02019-08-20 09:16:51 -040022inherit bash-completion
23
24do_install() {
25 oe_runmake DESTDIR=${D} install
26}