blob: 43367b550363df49ec676a1a4c61884c285dadda [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Mobile IPv6 and NEMO for Linux"
2DESCRIPTION = "UMIP is an open source implementation of Mobile IPv6 and NEMO \
3Basic Support for Linux. It is released under the GPLv2 license. It supports \
4the following IETF RFC: RFC6275 (Mobile IPv6), RFC3963 (NEMO), RFC3776 and \
5RFC4877 (IPsec and IKEv2)."
6HOMEPAGE = "http://umip.org/"
7SECTION = "System Environment/Base"
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=073dc31ccb2ebed70db54f1e8aeb4c33"
10DEPENDS = "openssl ipsec-tools radvd indent-native bison-native"
11
12SRC_URI = "git://git.umip.org/umip/umip.git \
13 file://add-dependency-to-support-parallel-compilation.patch \
14 file://mip6d \
15 file://mip6d.service \
16 file://0001-Add-format-string-to-fprintf-call.patch \
17 file://0001-replace-SIGCLD-with-SIGCHLD-and-include-sys-types.h.patch \
18 file://0002-replace-PTHREAD_MUTEX_FAST_NP-with-PTHREAD_MUTEX_NOR.patch \
19 file://0001-support-openssl-1.1.x.patch \
20 "
21SRCREV = "cbd441c5db719db554ff2b4fcb02fef88ae2f791"
22
Brad Bishopba6de432019-05-21 08:07:33 -040023# Depends on ipsec-tools which is already MACHINE_ARCH (and also RRECOMMENDS kernel modules)
24PACKAGE_ARCH = "${MACHINE_ARCH}"
25
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026S = "${WORKDIR}/git"
27
28EXTRA_OECONF = "--enable-vt"
29
30inherit autotools-brokensep systemd update-rc.d
31
32INITSCRIPT_NAME = "mip6d"
33INITSCRIPT_PARAMS = "start 64 . stop 36 0 1 2 3 4 5 6 ."
34
35SYSTEMD_SERVICE_${PN} = "mip6d.service"
36SYSTEMD_AUTO_ENABLE = "disable"
37
38do_install_append() {
39 install -D -m 0755 ${WORKDIR}/mip6d ${D}${sysconfdir}/init.d/mip6d
40 install -D -m 0644 ${WORKDIR}/mip6d.service ${D}${systemd_system_unitdir}/mip6d.service
41 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' \
42 -e 's,@SBINDIR@,${sbindir},g' \
43 ${D}${systemd_system_unitdir}/mip6d.service
44}
45
46RRECOMMENDS_${PN} = "kernel-module-mip6 kernel-module-ipv6"