blob: 348a0398f3bf92e4a55cb40e3eeef368d1b7e511 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Python GObject bindings"
2HOMEPAGE = "http://www.pygtk.org/"
3SECTION = "devel/python"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
6
Andrew Geissler1548c072019-02-22 16:03:50 -06007inherit gnomebase gobject-introspection distutils-base upstream-version-is-even
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008
Andrew Geissler1548c072019-02-22 16:03:50 -06009DEPENDS += "python glib-2.0"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010
Andrew Geissler1548c072019-02-22 16:03:50 -060011SRCNAME = "pygobject"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012SRC_URI = " \
13 http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014"
15
16SRC_URI[md5sum] = "3bac63c86bb963aa401f97859464aa90"
17SRC_URI[sha256sum] = "3dd3e21015d06e00482ea665fc1733b77e754a6ab656a5db5d7f7bfaf31ad0b0"
18
19S = "${WORKDIR}/${SRCNAME}-${PV}"
20
21BBCLASSEXTEND = "native"
22
Andrew Geissler1548c072019-02-22 16:03:50 -060023EXTRA_OECONF = "--disable-cairo"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024
25RDEPENDS_${PN} += "python-setuptools"
26RDEPENDS_${PN}_class-native = ""
27
28do_install_append() {
29 # Remove files that clash with python3-pygobject; their content is same
Andrew Geissler1548c072019-02-22 16:03:50 -060030 rm -r ${D}${includedir}/pygobject-3.0/pygobject.h ${D}${libdir}/pkgconfig
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031}