blob: b31d8eb4efb2478adc48c30c9dff6c2be9ecc58c [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "The Geolocation Service"
2DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \
3The primary goal of the Geoclue project is to make creating location-aware applications \
4as simple as possible, while the secondary goal is to ensure that no application \
5can access location information without explicit permission from user."
6LICENSE = "GPLv2.0+"
7SECTION = "console/network"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=8114b83a0435d8136b47bd70111ce5cd"
10
Brad Bishop316dfdd2018-06-25 12:45:53 -040011DEPENDS = "glib-2.0 dbus json-glib libsoup-2.4 intltool-native"
Patrick Williamsddad1a12017-02-23 20:36:32 -060012
Brad Bishop316dfdd2018-06-25 12:45:53 -040013inherit autotools pkgconfig gtk-doc gobject-introspection
Patrick Williamsddad1a12017-02-23 20:36:32 -060014
15SRC_URI = " \
16 http://www.freedesktop.org/software/geoclue/releases/2.4/geoclue-${PV}.tar.xz \
17"
18
19SRC_URI[md5sum] = "d2a5b05f4bad032673fe23afbce27926"
20SRC_URI[sha256sum] = "9c43fb9d0c12067ea64400500abb0640194947d4c2c55e38545afe5d9c5c315c"
21
22export BUILD_SYS
23export HOST_SYS
24export STAGING_INCDIR
25export STAGING_LIBDIR
26
27# Without this line, package is delcared a library and named libgeoclue*
28AUTO_LIBNAME_PKGS = ""
29
30PACKAGECONFIG ??= "3g modem-gps cdma nmea lib"
31PACKAGECONFIG[3g] = "--enable-3g-source,--disable-3g-source,modemmanager"
32PACKAGECONFIG[modem-gps] = "--enable-modem-gps-source,--disable-modem-gps-source,modemmanager"
33PACKAGECONFIG[cdma] = "--enable-cdma-source,--disable-cdma-source,modemmanager"
34PACKAGECONFIG[nmea] = "--enable-nmea-source,--disable-nmea-source,avahi"
35PACKAGECONFIG[lib] = "--enable-libgeoclue,--disable-libgeoclue,gobject-introspection"
36
37EXTRA_OECONF += " \
38 --with-dbus-service-user=root \
39 --with-dbus-sys-dir=${sysconfdir}/dbus-1/system.d \
40 --enable-demo-agent=no \
41"
42
43FILES_${PN} += " \
44 ${datadir}/dbus-1/system-services \
45 ${libdir} \
46 ${systemd_unitdir} \
47 ${prefix}/libexec \
48"
49
50FILES_${PN}-dev += " \
51 ${datadir}/dbus-1/interfaces \
52 ${datadir}/gir-1.0 \
53"