blob: 42cdb0430a6b1f243cff2a1b85c4ec4ea8f24999 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001require go-${PV}.inc
2require go-target.inc
Brad Bishopa5c52ff2018-11-23 10:55:50 +13003
4export GOBUILDMODE=""
5
6# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but mips
7# doesn't support -buildmode=pie, so skip the QA checking for mips and its
8# variants.
9python() {
10 if 'mips' in d.getVar('TARGET_ARCH'):
11 d.appendVar('INSANE_SKIP_%s' % d.getVar('PN'), " textrel")
12 else:
13 d.setVar('GOBUILDMODE', 'pie')
14}