blob: 85923e47596e23f34df7002ea87c51703b8b10ed [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Syntax highlight utility"
2DESCRIPTION = "Source-highlight converts source code to formatted text with syntax highlighting."
3HOMEPAGE = "https://www.gnu.org/software/src-highlite/"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ff95bfe019feaf92f524b73dd79e76eb"
6
7SRC_URI = "${GNU_MIRROR}/src-highlite/${BPN}-${PV}.tar.gz \
8 file://0001-source-highlight.pc.in-do-not-add-Boost-s-libraries-.patch"
9SRC_URI[md5sum] = "3243470706ef5fefdc3e43b5306a4e41"
10SRC_URI[sha256sum] = "01336a7ea1d1ccc374201f7b81ffa94d0aecb33afc7d6903ebf9fbf33a55ada3"
11
12inherit autotools
13
14DEPENDS_append = " boost"
15
16DEPENDS_append_class-target = " source-highlight-native"
17
18EXTRA_OECONF = "--with-boost=yes --with-boost-libdir=${STAGING_DIR_TARGET}${libdir}"
19
20BBCLASSEXTEND = "native"
21
22# source-highlight is using its own binary from the build tree to make documentation
23# let's substitute the native binary instead
24do_configure_prepend_class-target () {
25 sed -i -e 's,^SRCHILITEEXE = $(top_builddir).*,SRCHILITEEXE = source-highlight,' ${S}/doc/Makefile.am
26}
27
28RDEPENDS_source-highlight += "bash"