blob: b7ef7545ae513b0c89b4185223808b730214ece8 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GNOME library for reading .desktop files"
2SECTION = "x11/gnome"
3LICENSE = "GPLv2 & LGPLv2"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05004LIC_FILES_CHKSUM = " \
5 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
7"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
9BPN = "gnome-desktop"
10
11GNOMEBASEBUILDCLASS = "meson"
12
13inherit gnomebase itstool pkgconfig upstream-version-is-even gobject-introspection features_check
14
15# gobject-introspection is mandatory and cannot be configured
16REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
17UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
18
Andrew Geisslerc87764f2020-06-27 00:16:32 -050019SRC_URI[archive.md5sum] = "75e828342e51c88c866dcdd46c021d26"
20SRC_URI[archive.sha256sum] = "4bed119fa25ea0ff7880928142365c3c8726585fc072bc147157e66b63e96b7e"
Andrew Geissler82c905d2020-04-13 13:39:40 -050021
22SRC_URI += " \
23 file://gnome-desktop-thumbnail-don-t-assume-time_t-is-long.patch \
24 file://0001-meson.build-Disable-libseccomp-for-all-archs.patch \
25"
26
27DEPENDS += "gsettings-desktop-schemas virtual/libx11 gtk+3 startup-notification xkeyboard-config iso-codes udev"
28
29inherit features_check gtk-doc
30REQUIRED_DISTRO_FEATURES += "x11"
31
32GTKDOC_MESON_OPTION = "gtk_doc"
33EXTRA_OEMESON = "-Ddesktop_docs=false"
34
35PACKAGES =+ "libgnome-desktop3"
36FILES_libgnome-desktop3 = "${libdir}/lib*${SOLIBS} ${datadir}/libgnome-desktop*/pnp.ids ${datadir}/gnome/*xml"
37
38RRECOMMENDS_libgnome-desktop3 += "gsettings-desktop-schemas"