blob: 00a5c480da1989e73dff5afdfa7aa12344110249 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Linux libcamera framework"
2SECTION = "libs"
3
Andrew Geisslerc87764f2020-06-27 00:16:32 -05004LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
Brad Bishope42b3e32020-01-15 22:08:42 -05005
6LIC_FILES_CHKSUM = "\
Andrew Geisslerc87764f2020-06-27 00:16:32 -05007 file://LICENSES/GPL-2.0-or-later.txt;md5=fed54355545ffd980b814dab4a3b312c \
8 file://LICENSES/LGPL-2.1-or-later.txt;md5=2a4f4fd2128ea2f65047ee63fbca9f68 \
Brad Bishope42b3e32020-01-15 22:08:42 -05009"
10
11SRC_URI = " \
12 git://linuxtv.org/libcamera.git;protocol=git \
Brad Bishope42b3e32020-01-15 22:08:42 -050013"
14
Andrew Geisslerc87764f2020-06-27 00:16:32 -050015SRCREV = "5f2f9406cebc668f0d69007d1ea59ef3c56ef28c"
Brad Bishope42b3e32020-01-15 22:08:42 -050016
Andrew Geisslerc87764f2020-06-27 00:16:32 -050017PV = "202006+git${SRCPV}"
Brad Bishope42b3e32020-01-15 22:08:42 -050018
19S = "${WORKDIR}/git"
20
Andrew Geisslerc87764f2020-06-27 00:16:32 -050021DEPENDS = "python3-pyyaml-native udev gnutls boost"
Brad Bishope42b3e32020-01-15 22:08:42 -050022DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'qt', 'qtbase qtbase-native', '', d)}"
23
24RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland qt', 'qtwayland', '', d)}"
25
26inherit meson pkgconfig python3native
27
28FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig"
29FILES_${PN} += " ${libdir}/libcamera.so"
30