blob: 59deb15b636fafbd59c670449d9fadb96390729d [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "http://talloc.samba.org"
3SECTION = "libs"
4LICENSE = "LGPL-3.0+ & GPL-3.0+"
5LIC_FILES_CHKSUM = "file://talloc.h;beginline=3;endline=27;md5=a301712782cad6dd6d5228bfa7825249 \
6 file://pytalloc.h;beginline=1;endline=18;md5=2c498cc6f2263672483237b20f46b43d"
7
8
Andrew Geisslerc87764f2020-06-27 00:16:32 -05009SRC_URI = "https://www.samba.org/ftp/talloc/talloc-${PV}.tar.gz \
Brad Bishop26bdd442019-08-16 17:08:17 -040010 file://options-2.2.0.patch \
11 file://0001-waf-add-support-of-cross_compile.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012"
Brad Bishopc1d34332019-09-09 14:56:00 -040013SRC_URI[md5sum] = "8416b153547add81cd1a4d24e598c890"
14SRC_URI[sha256sum] = "75d5bcb34482545a82ffb06da8f6c797f963a0da450d0830c669267b14992fc6"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
16inherit waf-samba
17
18PACKAGECONFIG ??= "\
19 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
20 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
21"
22PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
23PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
24PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
25PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
26PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
27PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
28
29SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"
30
31S = "${WORKDIR}/talloc-${PV}"
32
Brad Bishop26bdd442019-08-16 17:08:17 -040033#cross_compile cannot use preforked process, since fork process earlier than point subproces.popen
34#to cross Popen
35export WAF_NO_PREFORK="yes"
36
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080037EXTRA_OECONF += "--disable-rpath \
38 --disable-rpath-install \
39 --bundled-libraries=NONE \
40 --builtin-libraries=replace \
41 --disable-silent-rules \
42 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
43 "
44
45PACKAGES += "pytalloc pytalloc-dev"
46
47RPROVIDES_${PN}-dbg += "pytalloc-dbg"
48
49FILES_pytalloc = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/* \
50 ${libdir}/libpytalloc-util.so.2 \
51 ${libdir}/libpytalloc-util.so.2.1.1 \
52 "
53FILES_pytalloc-dev = "${libdir}/libpytalloc-util.so"
Brad Bishop26bdd442019-08-16 17:08:17 -040054RDEPENDS_pytalloc = "python3"