blob: eae8275d6dbdb4195e2e4c1a855574557609db20 [file] [log] [blame]
Andrew Geisslereafcbb82020-06-05 17:59:17 -05001SUMMARY = "Simple construction, analysis and modification of binary data."
2HOMEPAGE = "https://github.com/scott-griffiths/bitstring"
3AUTHOR = "Scott Griffiths <dr.scottgriffiths@gmail.com>"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d973e8e0c311da41424357236b7b8908"
6
7SRC_URI[md5sum] = "18661a3e5c47c59bd926dd0fefae0baa"
8SRC_URI[sha256sum] = "fdf3eb72b229d2864fb507f8f42b1b2c57af7ce5fec035972f9566de440a864a"
9
10PYPI_PACKAGE = "bitstring"
11
12inherit pypi setuptools3
13
14RDEPENDS_${PN} = "\
15 ${PYTHON_PN}-core \
16 ${PYTHON_PN}-numbers \
17 ${PYTHON_PN}-mmap \
18"
19
20BBCLASSEXTEND = "native nativesdk"