blob: 568ba198984bd9c2ac6a17d51cee5377222ef1dc [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001DESCRIPTION = "Incremental is a small library that versions your Python projects"
2HOMEPAGE = "https://github.com/twisted/incremental"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=6ca9b07f08e2c72d48c74d363d1e0e15"
5
6SRC_URI[md5sum] = "602746e0d438e075a5a9e0678140bba2"
7SRC_URI[sha256sum] = "7b751696aaf36eebfab537e458929e194460051ccad279c72b755a167eebd4b3"
8
9inherit pypi setuptools3
10
11RDEPENDS_${PN} += " \
12 ${PYTHON_PN}-twisted \
13 ${PYTHON_PN}-click \
14"
15
16# -native is needed to build python[3]-twisted, however, we need to take steps to
17# prevent a circular dependency. The build apparently does not use the part of
18# python-incremental which uses python-twisted, so this hack is OK.
19RDEPENDS_${PYTHON_PN}-incremental-native_remove = "${PYTHON_PN}-twisted-native"
20BBCLASSEXTEND = "native"