blob: 36f9c911b8ae50bbb210bd98bb8ef3d725ecc4b2 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Self-contained ISO 3166-1 country definitions"
2HOMEPAGE = "https://pypi.org/project/iso3166/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5e2f4edc7e7408a82e4a1d05f229b695"
5
6SRC_URI[md5sum] = "53c313c7ae8721e40ddd5e7a01bbcb7e"
7SRC_URI[sha256sum] = "b1e58dbcf50fbb2c9c418ec7a6057f0cdb30b8f822ac852f72e71ba769dae8c5"
8
Andrew Geisslerc87764f2020-06-27 00:16:32 -05009inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS_${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
Andrew Geissler82c905d2020-04-13 13:39:40 -050023
24RDEPENDS_${PN} += "python3-numbers"
25
26BBCLASSEXTEND = "native nativesdk"