Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Perl library for transparent SSL" |
| 2 | DESCRIPTION = "This module is a true drop-in replacement for IO::Socket::INET that \ |
| 3 | uses SSL to encrypt data before it is transferred to a remote server \ |
| 4 | or client. IO::Socket::SSL supports all the extra features that one \ |
| 5 | needs to write a full-featured SSL client or server application: \ |
| 6 | multiple SSL contexts, cipher selection, certificate verification, and \ |
| 7 | SSL version selection. As an extra bonus, it works perfectly with \ |
| 8 | mod_perl." |
| 9 | HOMEPAGE = "http://search.cpan.org/dist/IO-Socket-SSL/" |
| 10 | SECTION = "libs" |
| 11 | |
| 12 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
| 13 | LIC_FILES_CHKSUM = "file://META.yml;beginline=12;endline=12;md5=963ce28228347875ace682de56eef8e8" |
| 14 | |
| 15 | RDEPENDS:${PN} += "\ |
| 16 | libmozilla-ca-perl \ |
| 17 | libnet-ssleay-perl \ |
| 18 | perl-module-autoloader \ |
| 19 | perl-module-io-socket \ |
| 20 | perl-module-scalar-util \ |
| 21 | " |
| 22 | |
| 23 | SRC_URI = "${CPAN_MIRROR}/authors/id/S/SU/SULLR/IO-Socket-SSL-${PV}.tar.gz" |
| 24 | SRC_URI[sha256sum] = "4cf83737a72b0970948b494bc9ddab7f725420a0ca0152d25c7e48ef8fa2b6a1" |
| 25 | |
| 26 | S = "${WORKDIR}/IO-Socket-SSL-${PV}" |
| 27 | |
| 28 | inherit cpan ptest-perl |
| 29 | |
| 30 | do_install:append () { |
| 31 | mkdir -p ${D}${docdir}/${PN}/ |
| 32 | cp ${S}/BUGS ${D}${docdir}/${PN}/ |
| 33 | cp ${S}/Changes ${D}${docdir}/${PN}/ |
| 34 | cp ${S}/README ${D}${docdir}/${PN}/ |
| 35 | cp -pRP ${S}/docs ${D}${docdir}/${PN}/ |
| 36 | cp -pRP ${S}/certs ${D}${docdir}/${PN}/ |
| 37 | cp -pRP ${S}/example ${D}${docdir}/${PN}/ |
| 38 | } |
| 39 | |
| 40 | RDEPENDS:${PN}-ptest += "\ |
| 41 | libnet-libidn-perl \ |
| 42 | liburi-perl \ |
| 43 | perl-module-file-glob \ |
| 44 | perl-module-findbin \ |
| 45 | perl-module-io-socket-inet \ |
| 46 | perl-module-io-socket-ip \ |
| 47 | perl-module-perlio \ |
| 48 | perl-module-perlio-scalar \ |
| 49 | perl-module-test-more \ |
| 50 | " |
| 51 | |
| 52 | do_install_ptest:append () { |
| 53 | cp -r ${B}/certs ${D}${PTEST_PATH} |
| 54 | } |
| 55 | |
| 56 | BBCLASSEXTEND = "native" |