blob: 1e540350841756baac80f0c7f95b934b5059a27e [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# NOTE - When using this class the user is responsible for ensuring that
3# TRANSLATED_TARGET_ARCH is added into PN. This ensures that if the TARGET_ARCH
4# is changed, another nativesdk xxx-canadian-cross can be installed
5#
6
7
8# SDK packages are built either explicitly by the user,
9# or indirectly via dependency. No need to be in 'world'.
10EXCLUDE_FROM_WORLD = "1"
Brad Bishop19323692019-04-05 15:28:33 -040011NATIVESDKLIBC ?= "libc-glibc"
12LIBCOVERRIDE = ":${NATIVESDKLIBC}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013CLASSOVERRIDE = "class-cross-canadian"
14STAGING_BINDIR_TOOLCHAIN = "${STAGING_DIR_NATIVE}${bindir_native}/${SDK_ARCH}${SDK_VENDOR}-${SDK_OS}:${STAGING_DIR_NATIVE}${bindir_native}/${TARGET_ARCH}${TARGET_VENDOR}-${TARGET_OS}"
15
16#
17# Update BASE_PACKAGE_ARCH and PACKAGE_ARCHS
18#
19PACKAGE_ARCH = "${SDK_ARCH}-${SDKPKGSUFFIX}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020BASECANADIANEXTRAOS ?= "linux-musl"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060021CANADIANEXTRAOS = "${BASECANADIANEXTRAOS}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022CANADIANEXTRAVENDOR = ""
23MODIFYTOS ??= "1"
24python () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025 archs = d.getVar('PACKAGE_ARCHS').split()
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026 sdkarchs = []
27 for arch in archs:
28 sdkarchs.append(arch + '-${SDKPKGSUFFIX}')
29 d.setVar('PACKAGE_ARCHS', " ".join(sdkarchs))
30
31 # Allow the following code segment to be disabled, e.g. meta-environment
Brad Bishop6e60e8b2018-02-01 10:27:11 -050032 if d.getVar("MODIFYTOS") != "1":
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033 return
34
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080035 if d.getVar("TCLIBC") in [ 'baremetal', 'newlib' ]:
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036 return
37
Brad Bishop6e60e8b2018-02-01 10:27:11 -050038 tos = d.getVar("TARGET_OS")
Andrew Geisslerc926e172021-05-07 16:11:35 -050039 whitelist = ["mingw32"]
Patrick Williamsc0f7c042017-02-23 20:41:17 -060040 extralibcs = [""]
Brad Bishop6e60e8b2018-02-01 10:27:11 -050041 if "musl" in d.getVar("BASECANADIANEXTRAOS"):
Patrick Williamsc0f7c042017-02-23 20:41:17 -060042 extralibcs.append("musl")
Brad Bishop316dfdd2018-06-25 12:45:53 -040043 for variant in ["", "spe", "x32", "eabi", "n32", "_ilp32"]:
Patrick Williamsc0f7c042017-02-23 20:41:17 -060044 for libc in extralibcs:
Patrick Williamsc124f4f2015-09-15 14:41:29 -050045 entry = "linux"
46 if variant and libc:
47 entry = entry + "-" + libc + variant
48 elif variant:
49 entry = entry + "-gnu" + variant
50 elif libc:
51 entry = entry + "-" + libc
52 whitelist.append(entry)
53 if tos not in whitelist:
Brad Bishop6e60e8b2018-02-01 10:27:11 -050054 bb.fatal("Building cross-candian for an unknown TARGET_SYS (%s), please update cross-canadian.bbclass" % d.getVar("TARGET_SYS"))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050055
56 for n in ["PROVIDES", "DEPENDS"]:
Brad Bishop6e60e8b2018-02-01 10:27:11 -050057 d.setVar(n, d.getVar(n))
58 d.setVar("STAGING_BINDIR_TOOLCHAIN", d.getVar("STAGING_BINDIR_TOOLCHAIN"))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050059 for prefix in ["AR", "AS", "DLLTOOL", "CC", "CXX", "GCC", "LD", "LIPO", "NM", "OBJDUMP", "RANLIB", "STRIP", "WINDRES"]:
60 n = prefix + "_FOR_TARGET"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050061 d.setVar(n, d.getVar(n))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050062 # This is a bit ugly. We need to zero LIBC/ABI extension which will change TARGET_OS
63 # however we need the old value in some variables. We expand those here first.
Brad Bishop6e60e8b2018-02-01 10:27:11 -050064 tarch = d.getVar("TARGET_ARCH")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050065 if tarch == "x86_64":
66 d.setVar("LIBCEXTENSION", "")
67 d.setVar("ABIEXTENSION", "")
Patrick Williamsc0f7c042017-02-23 20:41:17 -060068 d.appendVar("CANADIANEXTRAOS", " linux-gnux32")
Brad Bishop6e60e8b2018-02-01 10:27:11 -050069 for extraos in d.getVar("BASECANADIANEXTRAOS").split():
Patrick Williamsc0f7c042017-02-23 20:41:17 -060070 d.appendVar("CANADIANEXTRAOS", " " + extraos + "x32")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050071 elif tarch == "powerpc":
72 # PowerPC can build "linux" and "linux-gnuspe"
73 d.setVar("LIBCEXTENSION", "")
74 d.setVar("ABIEXTENSION", "")
Patrick Williamsc0f7c042017-02-23 20:41:17 -060075 d.appendVar("CANADIANEXTRAOS", " linux-gnuspe")
Brad Bishop6e60e8b2018-02-01 10:27:11 -050076 for extraos in d.getVar("BASECANADIANEXTRAOS").split():
Patrick Williamsc0f7c042017-02-23 20:41:17 -060077 d.appendVar("CANADIANEXTRAOS", " " + extraos + "spe")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050078 elif tarch == "mips64":
Patrick Williamsc0f7c042017-02-23 20:41:17 -060079 d.appendVar("CANADIANEXTRAOS", " linux-gnun32")
Brad Bishop6e60e8b2018-02-01 10:27:11 -050080 for extraos in d.getVar("BASECANADIANEXTRAOS").split():
Patrick Williamsc0f7c042017-02-23 20:41:17 -060081 d.appendVar("CANADIANEXTRAOS", " " + extraos + "n32")
Patrick Williamsf1e5d692016-03-30 15:21:19 -050082 if tarch == "arm" or tarch == "armeb":
Brad Bishopd7bf8c12018-02-25 22:55:05 -050083 d.appendVar("CANADIANEXTRAOS", " linux-gnueabi linux-musleabi")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050084 d.setVar("TARGET_OS", "linux-gnueabi")
85 else:
86 d.setVar("TARGET_OS", "linux")
87
88 # Also need to handle multilib target vendors
Brad Bishop6e60e8b2018-02-01 10:27:11 -050089 vendors = d.getVar("CANADIANEXTRAVENDOR")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050090 if not vendors:
91 vendors = all_multilib_tune_values(d, 'TARGET_VENDOR')
Brad Bishop6e60e8b2018-02-01 10:27:11 -050092 origvendor = d.getVar("TARGET_VENDOR_MULTILIB_ORIGINAL")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050093 if origvendor:
94 d.setVar("TARGET_VENDOR", origvendor)
95 if origvendor not in vendors.split():
96 vendors = origvendor + " " + vendors
97 d.setVar("CANADIANEXTRAVENDOR", vendors)
98}
99MULTIMACH_TARGET_SYS = "${PACKAGE_ARCH}${HOST_VENDOR}-${HOST_OS}"
100
101INHIBIT_DEFAULT_DEPS = "1"
102
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500103STAGING_DIR_HOST = "${RECIPE_SYSROOT}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500104
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500105TOOLCHAIN_OPTIONS = " --sysroot=${RECIPE_SYSROOT}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500106
107PATH_append = ":${TMPDIR}/sysroots/${HOST_ARCH}/${bindir_cross}"
108PKGHIST_DIR = "${TMPDIR}/pkghistory/${HOST_ARCH}-${SDKPKGSUFFIX}${HOST_VENDOR}-${HOST_OS}/"
109
110HOST_ARCH = "${SDK_ARCH}"
111HOST_VENDOR = "${SDK_VENDOR}"
112HOST_OS = "${SDK_OS}"
113HOST_PREFIX = "${SDK_PREFIX}"
114HOST_CC_ARCH = "${SDK_CC_ARCH}"
115HOST_LD_ARCH = "${SDK_LD_ARCH}"
116HOST_AS_ARCH = "${SDK_AS_ARCH}"
117
118#assign DPKG_ARCH
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500119DPKG_ARCH = "${@debian_arch_map(d.getVar('SDK_ARCH'), '')}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500120
121CPPFLAGS = "${BUILDSDK_CPPFLAGS}"
122CFLAGS = "${BUILDSDK_CFLAGS}"
123CXXFLAGS = "${BUILDSDK_CFLAGS}"
124LDFLAGS = "${BUILDSDK_LDFLAGS} \
125 -Wl,-rpath-link,${STAGING_LIBDIR}/.. \
126 -Wl,-rpath,${libdir}/.. "
127
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500128#
129# We need chrpath >= 0.14 to ensure we can deal with 32 and 64 bit
130# binaries
131#
132DEPENDS_append = " chrpath-replacement-native"
133EXTRANATIVEPATH += "chrpath-native"
134
135# Path mangling needed by the cross packaging
136# Note that we use := here to ensure that libdir and includedir are
137# target paths.
138target_base_prefix := "${base_prefix}"
139target_prefix := "${prefix}"
140target_exec_prefix := "${exec_prefix}"
141target_base_libdir = "${target_base_prefix}/${baselib}"
142target_libdir = "${target_exec_prefix}/${baselib}"
143target_includedir := "${includedir}"
144
145# Change to place files in SDKPATH
146base_prefix = "${SDKPATHNATIVE}"
147prefix = "${SDKPATHNATIVE}${prefix_nativesdk}"
148exec_prefix = "${SDKPATHNATIVE}${prefix_nativesdk}"
149bindir = "${exec_prefix}/bin/${TARGET_ARCH}${TARGET_VENDOR}-${TARGET_OS}"
150sbindir = "${bindir}"
151base_bindir = "${bindir}"
152base_sbindir = "${bindir}"
153libdir = "${exec_prefix}/lib/${TARGET_ARCH}${TARGET_VENDOR}-${TARGET_OS}"
154libexecdir = "${exec_prefix}/libexec/${TARGET_ARCH}${TARGET_VENDOR}-${TARGET_OS}"
155
156FILES_${PN} = "${prefix}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500157
158export PKG_CONFIG_DIR = "${STAGING_DIR_HOST}${layout_libdir}/pkgconfig"
159export PKG_CONFIG_SYSROOT_DIR = "${STAGING_DIR_HOST}"
160
161do_populate_sysroot[stamp-extra-info] = ""
162do_packagedata[stamp-extra-info] = ""
163
164USE_NLS = "${SDKUSE_NLS}"
165
166# We have to us TARGET_ARCH but we care about the absolute value
167# and not any particular tune that is enabled.
168TARGET_ARCH[vardepsexclude] = "TUNE_ARCH"
169
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500170PKGDATA_DIR = "${TMPDIR}/pkgdata/${SDK_SYS}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500171# If MLPREFIX is set by multilib code, shlibs
172# points to the wrong place so force it
173SHLIBSDIRS = "${PKGDATA_DIR}/nativesdk-shlibs2"
174SHLIBSWORKDIR = "${PKGDATA_DIR}/nativesdk-shlibs2"
175
176cross_canadian_bindirlinks () {
177 for i in linux ${CANADIANEXTRAOS}
178 do
179 for v in ${CANADIANEXTRAVENDOR}
180 do
181 d=${D}${bindir}/../${TARGET_ARCH}$v-$i
182 if [ -d $d ];
183 then
184 continue
185 fi
186 install -d $d
187 for j in `ls ${D}${bindir}`
188 do
189 p=${TARGET_ARCH}$v-$i-`echo $j | sed -e s,${TARGET_PREFIX},,`
190 ln -s ../${TARGET_SYS}/$j $d/$p
191 done
192 done
193 done
194}