blob: 3d1e1c7e7968ea4e60718a7bbd638b4784b71634 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "nl80211 based CLI configuration utility for wireless devices"
2DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \
3wireless devices. It supports almost all new drivers that have been added \
4to the kernel recently. "
Andrew Geissler6ce62a22020-11-30 19:58:47 -06005HOMEPAGE = "https://wireless.wiki.kernel.org/en/users/documentation/iw"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006SECTION = "base"
7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
9
10DEPENDS = "libnl"
11
12SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.gz \
13 file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \
14 file://separate-objdir.patch \
15"
16
Andrew Geissler6ce62a22020-11-30 19:58:47 -060017SRC_URI[sha256sum] = "6e7d3c9f8b4ee68e412f20fe229c9854c2dba383e3e650ce6af8eb8dbd12efc3"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018
19inherit pkgconfig
20
21EXTRA_OEMAKE = "\
22 -f '${S}/Makefile' \
23 \
24 'PREFIX=${prefix}' \
25 'SBINDIR=${sbindir}' \
26 'MANDIR=${mandir}' \
27"
28
29do_install() {
30 oe_runmake 'DESTDIR=${D}' install
31}