blob: bc6cc0d18315540f7a6723ae5a08e369706883c5 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A meta recipe to build native tools used by wic."
2
3LICENSE = "MIT"
4
5DEPENDS = "\
Andrew Geisslerd1e89492021-02-12 15:35:20 -06006 parted-native gptfdisk-native dosfstools-native \
Andrew Geisslerd25ed322020-06-27 00:28:28 -05007 mtools-native bmap-tools-native grub-native cdrtools-native \
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008 btrfs-tools-native squashfs-tools-native pseudo-native \
Andrew Geissler82c905d2020-04-13 13:39:40 -05009 e2fsprogs-native util-linux-native tar-native\
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010 "
Andrew Geisslerd1e89492021-02-12 15:35:20 -060011DEPENDS_append_x86 = " syslinux-native syslinux grub-efi systemd-boot"
12DEPENDS_append_x86-64 = " syslinux-native syslinux grub-efi systemd-boot"
13DEPENDS_append_x86-x32 = " syslinux-native syslinux grub-efi"
14DEPENDS_append_aarch64 = " grub-efi systemd-boot"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015
16INHIBIT_DEFAULT_DEPS = "1"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018inherit nopackages
19
20# The sysroot of wic-tools is needed for wic, but if rm_work is enabled, it will
21# be removed before wic has a chance to use it, hence the exclusion below.
22RM_WORK_EXCLUDE += "${PN}"
23
24python do_build_sysroot () {
25 bb.build.exec_func("extend_recipe_sysroot", d)
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026}
27addtask do_build_sysroot after do_prepare_recipe_sysroot before do_build