blob: b5e0561c15e62be406e81ad9fc58806d4381f755 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
Andrew Geisslerc926e172021-05-07 16:11:35 -050010LICENSE = "GPLv2 & LGPLv3+"
11LIC_FILES_CHKSUM = " \
12 file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067 \
13 file://libbtrfsutil/COPYING.LESSER;md5=3000208d539ec061b899bce1d9ce9404 \
14"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015SECTION = "base"
Andrew Geisslerc926e172021-05-07 16:11:35 -050016DEPENDS = "lzo util-linux zlib"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017DEPENDS_append_class-target = " udev"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018
Andrew Geissler82c905d2020-04-13 13:39:40 -050019SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
20 file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
21 "
Andrew Geisslerc926e172021-05-07 16:11:35 -050022SRCREV = "8d5051f279f7994fb80536ef8f846f06d121d898"
23S = "${WORKDIR}/git"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
Andrew Geisslerc926e172021-05-07 16:11:35 -050025PACKAGECONFIG ??= " \
26 programs \
27 convert \
28 python \
29 crypto-builtin \
30"
Andrew Geissler82c905d2020-04-13 13:39:40 -050031PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
Andrew Geisslerc926e172021-05-07 16:11:35 -050032PACKAGECONFIG[programs] = "--enable-programs,--disable-programs"
33PACKAGECONFIG[convert] = "--enable-convert --with-convert=ext2,--disable-convert --without-convert,e2fsprogs"
Andrew Geissler82c905d2020-04-13 13:39:40 -050034PACKAGECONFIG[python] = "--enable-python,--disable-python,python3-setuptools-native"
35PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
36
Andrew Geisslerc926e172021-05-07 16:11:35 -050037# Pick only one crypto provider
38PACKAGECONFIG[crypto-builtin] = "--with-crypto=builtin"
39PACKAGECONFIG[crypto-libgcrypt] = "--with-crypto=libgcrypt,,libgcrypt"
40PACKAGECONFIG[crypto-libsodium] = "--with-crypto=libsodium,,libsodium"
41PACKAGECONFIG[crypto-libkcapi] = "--with-crypto=libkcapi,,libkcapi"
42
Andrew Geissler82c905d2020-04-13 13:39:40 -050043inherit autotools-brokensep pkgconfig manpages
44inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'distutils3-base', '', d)}
45
46CLEANBROKEN = "1"
47
Andrew Geisslerc926e172021-05-07 16:11:35 -050048EXTRA_OECONF = "--enable-largefile"
Andrew Geissler82c905d2020-04-13 13:39:40 -050049EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
50EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}"
51EXTRA_PYTHON_CFLAGS_class-native = ""
52EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}"
53EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'"
54
55do_configure_prepend() {
56 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
57 mkdir -p ${S}/config
58 cp -f $(automake --print-libdir)/install-sh ${S}/config/
59}
60
Andrew Geissler82c905d2020-04-13 13:39:40 -050061
62do_install_append() {
63 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
64 oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
65 fi
66}
67
Andrew Geisslerc926e172021-05-07 16:11:35 -050068RDEPENDS_${PN} = "libgcc"
69
Andrew Geissler5a43b432020-06-13 10:46:56 -050070BBCLASSEXTEND = "native nativesdk"