blob: 8a5d3dc9bf2d10f1fad8701bc7808683fcaa1dd6 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001# Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "The LLVM Compiler Infrastructure"
5HOMEPAGE = "http://llvm.org"
Brad Bishopf3f93bb2019-10-16 14:33:32 -04006LICENSE = "Apache-2.0-with-LLVM-exception"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007SECTION = "devel"
8
Brad Bishopf3f93bb2019-10-16 14:33:32 -04009LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=8a15a0759ef07f2682d2ba4b893c9afe"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010
Brad Bishop08902b02019-08-20 09:16:51 -040011DEPENDS = "libffi libxml2 zlib libedit ninja-native llvm-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012
Andrew Geissler82c905d2020-04-13 13:39:40 -050013COMPATIBLE_HOST_riscv64 = "null"
14COMPATIBLE_HOST_riscv32 = "null"
15
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016RDEPENDS_${PN}_append_class-target = " ncurses-terminfo"
17
Brad Bishop19323692019-04-05 15:28:33 -040018inherit cmake pkgconfig
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019
20PROVIDES += "llvm${PV}"
21
Andrew Geisslerc926e172021-05-07 16:11:35 -050022MAJOR_VERSION = "12"
23MINOR_VERSION = "0"
Andrew Geissler90fd73c2021-03-05 15:25:55 -060024PATCH_VERSION = "0"
Brad Bishopf3f93bb2019-10-16 14:33:32 -040025
26PV = "${MAJOR_VERSION}.${MINOR_VERSION}.${PATCH_VERSION}"
27
Brad Bishopd7bf8c12018-02-25 22:55:05 -050028LLVM_RELEASE = "${PV}"
29LLVM_DIR = "llvm${LLVM_RELEASE}"
30
Brad Bishop19323692019-04-05 15:28:33 -040031BRANCH = "release/${MAJOR_VERSION}.x"
Andrew Geisslerc926e172021-05-07 16:11:35 -050032SRCREV = "fa0971b87fb2c9d14d1bba2551e61f02f18f329b"
Brad Bishop19323692019-04-05 15:28:33 -040033SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH} \
Brad Bishop08902b02019-08-20 09:16:51 -040034 file://0006-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch;striplevel=2 \
35 file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
Andrew Geissler09209ee2020-12-13 08:44:15 -060036 file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \
37 "
Brad Bishop19323692019-04-05 15:28:33 -040038
Andrew Geissler82c905d2020-04-13 13:39:40 -050039UPSTREAM_CHECK_GITTAGREGEX = "llvmorg-(?P<pver>\d+(\.\d+)+)"
40
Brad Bishop19323692019-04-05 15:28:33 -040041S = "${WORKDIR}/git/llvm"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050042
43LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install"
Brad Bishop19323692019-04-05 15:28:33 -040044
Brad Bishopd7bf8c12018-02-25 22:55:05 -050045def get_llvm_arch(bb, d, arch_var):
46 import re
47 a = d.getVar(arch_var)
Brad Bishop19323692019-04-05 15:28:33 -040048 if re.match(r'(i.86|athlon|x86.64)$', a): return 'X86'
49 elif re.match(r'arm$', a): return 'ARM'
50 elif re.match(r'armeb$', a): return 'ARM'
51 elif re.match(r'aarch64$', a): return 'AArch64'
52 elif re.match(r'aarch64_be$', a): return 'AArch64'
53 elif re.match(r'mips(isa|)(32|64|)(r6|)(el|)$', a): return 'Mips'
Brad Bishopf3f93bb2019-10-16 14:33:32 -040054 elif re.match(r'riscv(32|64)(eb|)$', a): return 'RISCV'
Brad Bishop19323692019-04-05 15:28:33 -040055 elif re.match(r'p(pc|owerpc)(|64)', a): return 'PowerPC'
Brad Bishopd7bf8c12018-02-25 22:55:05 -050056 else:
57 raise bb.parse.SkipRecipe("Cannot map '%s' to a supported LLVM architecture" % a)
58
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080059def get_llvm_host_arch(bb, d):
60 return get_llvm_arch(bb, d, 'HOST_ARCH')
61
Brad Bishopd7bf8c12018-02-25 22:55:05 -050062#
63# Default to build all OE-Core supported target arches (user overridable).
64#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080065LLVM_TARGETS ?= "AMDGPU;${@get_llvm_host_arch(bb, d)}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050066
67ARM_INSTRUCTION_SET_armv5 = "arm"
68ARM_INSTRUCTION_SET_armv4t = "arm"
69
70EXTRA_OECMAKE += "-DLLVM_ENABLE_ASSERTIONS=OFF \
71 -DLLVM_ENABLE_EXPENSIVE_CHECKS=OFF \
72 -DLLVM_ENABLE_PIC=ON \
73 -DLLVM_BINDINGS_LIST='' \
74 -DLLVM_LINK_LLVM_DYLIB=ON \
75 -DLLVM_ENABLE_FFI=ON \
Brad Bishop19323692019-04-05 15:28:33 -040076 -DLLVM_ENABLE_RTTI=ON \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050077 -DFFI_INCLUDE_DIR=$(pkg-config --variable=includedir libffi) \
78 -DLLVM_OPTIMIZED_TABLEGEN=ON \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080079 -DLLVM_TARGETS_TO_BUILD='${LLVM_TARGETS}' \
Brad Bishop19323692019-04-05 15:28:33 -040080 -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON \
Brad Bishop79641f22019-09-10 07:20:22 -040081 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050082 -G Ninja"
83
84EXTRA_OECMAKE_append_class-target = "\
85 -DCMAKE_CROSSCOMPILING:BOOL=ON \
86 -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm-tblgen${PV} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080087 -DLLVM_CONFIG_PATH=${STAGING_BINDIR_NATIVE}/llvm-config${PV} \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050088 "
89
90EXTRA_OECMAKE_append_class-nativesdk = "\
91 -DCMAKE_CROSSCOMPILING:BOOL=ON \
92 -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm-tblgen${PV} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080093 -DLLVM_CONFIG_PATH=${STAGING_BINDIR_NATIVE}/llvm-config${PV} \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050094 "
95
96do_configure_prepend() {
97# Fix paths in llvm-config
98 sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" ${S}/tools/llvm-config/llvm-config.cpp
99 sed -ri "s#/(bin|include|lib)(/?\")#/\1/${LLVM_DIR}\2#g" ${S}/tools/llvm-config/llvm-config.cpp
100 sed -ri "s#lib/${LLVM_DIR}#${baselib}/${LLVM_DIR}#g" ${S}/tools/llvm-config/llvm-config.cpp
101}
102
Andrew Geissler09209ee2020-12-13 08:44:15 -0600103# patch out build host paths for reproducibility
104do_compile_prepend_class-target() {
105 sed -i -e "s,${WORKDIR},,g" ${B}/tools/llvm-config/BuildVariables.inc
106}
107
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500108do_compile() {
Brad Bishop316dfdd2018-06-25 12:45:53 -0400109 ninja -v ${PARALLEL_MAKE}
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500110}
111
112do_compile_class-native() {
Brad Bishop316dfdd2018-06-25 12:45:53 -0400113 ninja -v ${PARALLEL_MAKE} llvm-config llvm-tblgen
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500114}
115
116do_install() {
Brad Bishop316dfdd2018-06-25 12:45:53 -0400117 DESTDIR=${LLVM_INSTALL_DIR} ninja -v install
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500118 install -D -m 0755 ${B}/bin/llvm-config ${D}${libdir}/${LLVM_DIR}/llvm-config
119
120 install -d ${D}${bindir}/${LLVM_DIR}
121 cp -r ${LLVM_INSTALL_DIR}${bindir}/* ${D}${bindir}/${LLVM_DIR}/
122
123 install -d ${D}${includedir}/${LLVM_DIR}
124 cp -r ${LLVM_INSTALL_DIR}${includedir}/* ${D}${includedir}/${LLVM_DIR}/
125
126 install -d ${D}${libdir}/${LLVM_DIR}
127
128 # The LLVM sources have "/lib" embedded and so we cannot completely rely on the ${libdir} variable
129 if [ -d ${LLVM_INSTALL_DIR}${libdir}/ ]; then
130 cp -r ${LLVM_INSTALL_DIR}${libdir}/* ${D}${libdir}/${LLVM_DIR}/
131 elif [ -d ${LLVM_INSTALL_DIR}${prefix}/lib ]; then
132 cp -r ${LLVM_INSTALL_DIR}${prefix}/lib/* ${D}${libdir}/${LLVM_DIR}/
133 elif [ -d ${LLVM_INSTALL_DIR}${prefix}/lib64 ]; then
134 cp -r ${LLVM_INSTALL_DIR}${prefix}/lib64/* ${D}${libdir}/${LLVM_DIR}/
135 fi
136
137 # Remove unnecessary cmake files
138 rm -rf ${D}${libdir}/${LLVM_DIR}/cmake
139
Brad Bishop19323692019-04-05 15:28:33 -0400140 ln -s ${LLVM_DIR}/libLLVM-${MAJOR_VERSION}${SOLIBSDEV} ${D}${libdir}/libLLVM-${MAJOR_VERSION}${SOLIBSDEV}
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500141
142 # We'll have to delete the libLLVM.so due to multiple reasons...
143 rm -rf ${D}${libdir}/${LLVM_DIR}/libLLVM.so
144 rm -rf ${D}${libdir}/${LLVM_DIR}/libLTO.so
145}
Brad Bishop19323692019-04-05 15:28:33 -0400146
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500147do_install_class-native() {
148 install -D -m 0755 ${B}/bin/llvm-tblgen ${D}${bindir}/llvm-tblgen${PV}
149 install -D -m 0755 ${B}/bin/llvm-config ${D}${bindir}/llvm-config${PV}
Brad Bishop19323692019-04-05 15:28:33 -0400150 install -D -m 0755 ${B}/lib/libLLVM-${MAJOR_VERSION}.so ${D}${libdir}/libLLVM-${MAJOR_VERSION}.so
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500151}
152
Brad Bishop19323692019-04-05 15:28:33 -0400153PACKAGES =+ "${PN}-bugpointpasses ${PN}-llvmhello ${PN}-libllvm ${PN}-liboptremarks ${PN}-liblto"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500154
Brad Bishop19323692019-04-05 15:28:33 -0400155RRECOMMENDS_${PN}-dev += "${PN}-bugpointpasses ${PN}-llvmhello ${PN}-liboptremarks"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500156
157FILES_${PN}-bugpointpasses = "\
158 ${libdir}/${LLVM_DIR}/BugpointPasses.so \
159"
Brad Bishop19323692019-04-05 15:28:33 -0400160
161FILES_${PN}-libllvm = "\
162 ${libdir}/${LLVM_DIR}/libLLVM-${MAJOR_VERSION}.so \
163 ${libdir}/libLLVM-${MAJOR_VERSION}.so \
164"
165
166FILES_${PN}-liblto += "\
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500167 ${libdir}/${LLVM_DIR}/libLTO.so.* \
168"
169
Brad Bishop19323692019-04-05 15:28:33 -0400170FILES_${PN}-liboptremarks += "\
Brad Bishopf3f93bb2019-10-16 14:33:32 -0400171 ${libdir}/${LLVM_DIR}/libRemarks.so.* \
Brad Bishop19323692019-04-05 15:28:33 -0400172"
173
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500174FILES_${PN}-llvmhello = "\
175 ${libdir}/${LLVM_DIR}/LLVMHello.so \
176"
177
Brad Bishop19323692019-04-05 15:28:33 -0400178FILES_${PN}-dev += " \
179 ${libdir}/${LLVM_DIR}/llvm-config \
Brad Bishopf3f93bb2019-10-16 14:33:32 -0400180 ${libdir}/${LLVM_DIR}/libRemarks.so \
Brad Bishop19323692019-04-05 15:28:33 -0400181 ${libdir}/${LLVM_DIR}/libLLVM-${MAJOR_VERSION}.${MINOR_VERSION}.${PATCH_VERSION}.so \
182"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500183
Brad Bishop19323692019-04-05 15:28:33 -0400184FILES_${PN}-staticdev += "\
185 ${libdir}/${LLVM_DIR}/*.a \
186"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500187
Brad Bishop19323692019-04-05 15:28:33 -0400188INSANE_SKIP_${PN}-libllvm += "dev-so"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500189
190BBCLASSEXTEND = "native nativesdk"