blob: cade4e0f51156eb0e2bea2b1d2845a297dd1edf3 [file] [log] [blame]
Andrew Geisslerc3d88e42020-10-02 09:45:00 -05001DESCRIPTION = "Implements a XML/HTML/XHTML Markup safe string for Python"
2HOMEPAGE = "http://github.com/mitsuhiko/markupsafe"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
5
6SRC_URI[md5sum] = "43fd756864fe42063068e092e220c57b"
7SRC_URI[sha256sum] = "29872e92839765e546828bb7754a68c418d927cd064fd4708fab9fe9c8bb116b"
8
9PYPI_PACKAGE = "MarkupSafe"
10inherit pypi setuptools3
Andrew Geisslerc926e172021-05-07 16:11:35 -050011inherit ${@bb.utils.filter('DISTRO_FEATURES', 'ptest', d)}
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050012
13RDEPENDS_${PN} += "${PYTHON_PN}-stringold"
14
15BBCLASSEXTEND = "native nativesdk"
16
17SRC_URI += " \
18 file://run-ptest \
19"
20
21RDEPENDS_${PN}-ptest += " \
22 ${PYTHON_PN}-pytest \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 cp -f ${S}/tests/* ${D}${PTEST_PATH}/tests/
28}