blob: 9ace037aa954ee7d598d2f8e9459c9ea263ed5a5 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter"
2DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \
3a back-end to a program such as ghostview, it can display PostScript and PDF \
4documents in an X11 environment. \
5\
6Furthermore, it can render PostScript and PDF files as graphics to be printed \
7on non-PostScript printers. Supported printers include common \
8dot-matrix, inkjet and laser models. \
9"
10HOMEPAGE = "http://www.ghostscript.com"
11SECTION = "console/utils"
12
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=70dc2bac4d0ce4448da873cd86b123fc"
15
16DEPENDS = "ghostscript-native tiff jpeg fontconfig cups libpng"
17DEPENDS_class-native = "libpng-native"
18
19UPSTREAM_CHECK_URI = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases"
20UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
21
Andrew Geissler4b740dc2020-05-05 08:54:39 -050022def gs_verdir(v):
23 return "".join(v.split("."))
24
25
26SRC_URI_BASE = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${@gs_verdir("${PV}")}/${BPN}-${PV}.tar.gz \
Andrew Geissler82c905d2020-04-13 13:39:40 -050027 file://ghostscript-9.15-parallel-make.patch \
28 file://ghostscript-9.16-Werror-return-type.patch \
29 file://do-not-check-local-libpng-source.patch \
30 file://avoid-host-contamination.patch \
31 file://mkdir-p.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050032"
33
34SRC_URI = "${SRC_URI_BASE} \
35 file://ghostscript-9.21-prevent_recompiling.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050036 file://cups-no-gcrypt.patch \
37 "
38
39SRC_URI_class-native = "${SRC_URI_BASE} \
40 file://ghostscript-9.21-native-fix-disable-system-libtiff.patch \
41 file://base-genht.c-add-a-preprocessor-define-to-allow-fope.patch \
42 "
43
Andrew Geisslerc926e172021-05-07 16:11:35 -050044SRC_URI[sha256sum] = "0646bb97f6f4d10a763f4919c54fa28b4fbdd3dff8e7de3410431c81762cade0"
Andrew Geissler82c905d2020-04-13 13:39:40 -050045
46# Put something like
47#
48# PACKAGECONFIG_append_pn-ghostscript = " x11"
49#
50# in local.conf to enable building with X11. Be careful. The order
51# of the overrides matters!
52#
53#PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
54PACKAGECONFIG_class-native = ""
55
56PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}, \
57 --without-x, virtual/libx11 libxext libxt gtk+3\
58 "
59
60EXTRA_OECONF = "--without-libpaper --with-system-libtiff --without-jbig2dec \
61 --with-fontpath=${datadir}/fonts \
62 --without-libidn --with-cups-serverbin=${exec_prefix}/lib/cups \
63 --with-cups-datadir=${datadir}/cups \
64 CUPSCONFIG="${STAGING_BINDIR_CROSS}/cups-config" \
65 "
66
67EXTRA_OECONF_append_mipsarcho32 = " --with-large_color_index=0"
68
69# Explicity disable libtiff, fontconfig,
70# freetype, cups for ghostscript-native
71EXTRA_OECONF_class-native = "--without-x --with-system-libtiff=no \
72 --without-jbig2dec --without-libpaper \
73 --with-fontpath=${datadir}/fonts \
74 --without-libidn --disable-fontconfig \
Andrew Geissler4b740dc2020-05-05 08:54:39 -050075 --enable-freetype --disable-cups "
Andrew Geissler82c905d2020-04-13 13:39:40 -050076
77# This has been fixed upstream but for now we need to subvert the check for time.h
78# http://bugs.ghostscript.com/show_bug.cgi?id=692443
79# http://bugs.ghostscript.com/show_bug.cgi?id=692426
80CFLAGS += "-DHAVE_SYS_TIME_H=1"
81BUILD_CFLAGS += "-DHAVE_SYS_TIME_H=1"
82
Andrew Geissler4b740dc2020-05-05 08:54:39 -050083inherit autotools-brokensep
Andrew Geissler82c905d2020-04-13 13:39:40 -050084
Andrew Geissler6ce62a22020-11-30 19:58:47 -060085do_configure_prepend_class-target () {
86 rm -rf ${S}/jpeg/
87}
88
Andrew Geissler82c905d2020-04-13 13:39:40 -050089do_configure_append () {
90 # copy tools from the native ghostscript build
91 if [ "${PN}" != "ghostscript-native" ]; then
92 mkdir -p obj/aux soobj
93 for i in genarch genconf mkromfs echogs gendev genht packps; do
94 cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i obj/aux/$i
95 done
96 fi
97}
98
99do_install_append () {
100 mkdir -p ${D}${datadir}/ghostscript/${PV}/
101 cp -r ${S}/Resource ${D}${datadir}/ghostscript/${PV}/
102 cp -r ${S}/iccprofiles ${D}${datadir}/ghostscript/${PV}/
103}
104
105do_compile_class-native () {
106 mkdir -p obj
107 for i in genarch genconf mkromfs echogs gendev genht packps; do
108 oe_runmake obj/aux/$i
109 done
110}
111
112do_install_class-native () {
113 install -d ${D}${bindir}/ghostscript-${PV}
114 for i in genarch genconf mkromfs echogs gendev genht packps; do
115 install -m 755 obj/aux/$i ${D}${bindir}/ghostscript-${PV}/$i
116 done
117}
118
119BBCLASSEXTEND = "native"
120
121# ghostscript does not supports "arc"
122COMPATIBLE_HOST = "^(?!arc).*"
123
124# some entries in NVD uses gpl_ghostscript
125CVE_PRODUCT = "ghostscript gpl_ghostscript"