blob: a622779e6a496c451286496bf018c3470ca1ad5b [file] [log] [blame]
Andrew Geisslerc926e172021-05-07 16:11:35 -05001require core-image-weston-sdk.bb
2require conf/distro/include/ptest-packagelists.inc
3
4DESCRIPTION += "Also includes ptest packages."
5
6# Include the full set of ptests
7IMAGE_INSTALL += "${PTESTS_FAST} ${PTESTS_SLOW}"
8
9# This image is sufficiently large (~1.8GB) that we need to be careful that it fits in a live
10# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
11# box) and explicitly add just 1100MB.
12# strace-ptest in particular needs more than 500MB
13IMAGE_OVERHEAD_FACTOR = "1.0"
14IMAGE_ROOTFS_EXTRA_SPACE = "1124288"
15
16# ptests need more memory than standard to avoid the OOM killer
17# also lttng-tools needs /tmp that has at least 1G
18QB_MEM = "-m 2048"
19
20# Sadly at the moment the full set of ptests is not robust enough and sporadically fails in random places
21PTEST_EXPECT_FAILURE = "1"