blob: df02befb66b785f9072cfd9c4c35ce2a0d870eea [file] [log] [blame]
Andrew Geisslerc926e172021-05-07 16:11:35 -05001require core-image-weston-sdk.bb
2require conf/distro/include/ptest-packagelists.inc
3
4# Include only fast (< 30 sec) ptests
5IMAGE_INSTALL += "${PTESTS_FAST}"
6
7DESCRIPTION += "Also includes ptest packages with fast execution times to allow for more automated QA."
8
9# This image is sufficiently large (~1.8GB) that it can't actually fit in a live
10# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
11# box) and explicitly add just 1500MB.
12# strace-ptest in particular needs more than 500MB
13IMAGE_OVERHEAD_FACTOR = "1.0"
14IMAGE_ROOTFS_EXTRA_SPACE = "1524288"
15
16# ptests need more memory than standard to avoid the OOM killer
17QB_MEM = "-m 1024"
18
19# Sadly at the moment the fast set of ptests is not robust enough and sporadically fails in a couple of places
20PTEST_EXPECT_FAILURE = "1"