blob: 8b1c96fc4aed8c5e361970326e87f51d1a570f83 [file] [log] [blame]
Andrew Geisslerc926e172021-05-07 16:11:35 -05001SUMMARY = "XWayland is an X Server that runs under Wayland."
2DESCRIPTION = "XWayland is an X Server running as a Wayland client, \
3and thus is capable of displaying native X11 client applications in a \
4Wayland compositor environment. The goal of XWayland is to facilitate \
5the transition from X Window System to Wayland environments, providing \
6a way to run unported applications in the meantime."
7HOMEPAGE = "https://fedoraproject.org/wiki/Changes/XwaylandStandalone"
8
9LICENSE = "MIT-X"
10LIC_FILES_CHKSUM = "file://COPYING;md5=5df87950af51ac2c5822094553ea1880"
11
12SRC_URI = "https://www.x.org/archive/individual/xserver/xwayland-${PV}.tar.xz"
13SRC_URI[sha256sum] = "31f261ce51bbee76a6ca3ec02aa367ffa2b5efa2b98412df57ccefd7a19003ce"
14
15inherit meson features_check
16REQUIRED_DISTRO_FEATURES = "x11 opengl"
17
18DEPENDS += "xorgproto xtrans pixman libxkbfile libxfont2 wayland wayland-native wayland-protocols libdrm libepoxy"
19
20do_install_append() {
21 # remove files not needed and clashing with xserver-xorg
22 rm -rf ${D}/${libdir}/xorg/
23}
24
25FILES_${PN} += "${libdir}/xorg/protocol.txt"
26