blob: 6132daf1a184e7b5e45c8e0d5e159a26e93f9cea [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit Control"
3DESCRIPTION = "The Linux trace toolkit is a suite of tools designed \
4to extract program execution details from the Linux operating system \
5and interpret them."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06006HOMEPAGE = "https://github.com/lttng/lttng-tools"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
8LICENSE = "GPLv2 & LGPLv2.1"
Andrew Geissler1e34c2d2020-05-29 16:02:59 -05009LIC_FILES_CHKSUM = "file://LICENSE;md5=40ef17463fbd6f377db3c47b1cbaded8 \
10 file://LICENSES/GPL-2.0;md5=e68f69a54b44ba526ad7cb963e18fbce \
11 file://LICENSES/LGPL-2.1;md5=9920968d0f2ff585ce61fae30344dd95"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
Andrew Geisslerc9f78652020-09-18 14:11:35 -050013include lttng-platforms.inc
14
Andrew Geissler82c905d2020-04-13 13:39:40 -050015DEPENDS = "liburcu popt libxml2 util-linux"
16RDEPENDS_${PN} = "libgcc"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050017RRECOMMENDS_${PN} += "${LTTNGMODULES}"
18RDEPENDS_${PN}-ptest += "make perl bash gawk babeltrace procps perl-module-overloading coreutils util-linux kmod ${LTTNGMODULES} sed python3-core"
Andrew Geissler82c905d2020-04-13 13:39:40 -050019RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
20RDEPENDS_${PN}-ptest_append_libc-musl = " musl-utils"
21# babelstats.pl wants getopt-long
22RDEPENDS_${PN}-ptest += "perl-module-getopt-long"
23
24PYTHON_OPTION = "am_cv_python_pyexecdir='${PYTHON_SITEPACKAGES_DIR}' \
25 am_cv_python_pythondir='${PYTHON_SITEPACKAGES_DIR}' \
26 PYTHON_INCLUDE='-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION}${PYTHON_ABI}' \
27"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050028PACKAGECONFIG ??= "${LTTNGUST}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050029PACKAGECONFIG[python] = "--enable-python-bindings ${PYTHON_OPTION},,python3 swig-native"
30PACKAGECONFIG[lttng-ust] = "--with-lttng-ust, --without-lttng-ust, lttng-ust"
31PACKAGECONFIG[kmod] = "--with-kmod, --without-kmod, kmod"
32PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native"
Andrew Geissler82c905d2020-04-13 13:39:40 -050033
34SRC_URI = "https://lttng.org/files/lttng-tools/lttng-tools-${PV}.tar.bz2 \
Andrew Geissler82c905d2020-04-13 13:39:40 -050035 file://0001-tests-do-not-strip-a-helper-library.patch \
36 file://run-ptest \
37 file://lttng-sessiond.service \
38 file://0001-tests-regression-disable-the-tools-live-tests.patch \
Andrew Geissler90fd73c2021-03-05 15:25:55 -060039 file://determinism.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050040 "
41
Andrew Geissler95ac1b82021-03-31 14:34:31 -050042SRC_URI[sha256sum] = "2890da230edd523fcf497e9eb28133b7606d64fa01bcbffadbfcba42104db153"
Andrew Geissler82c905d2020-04-13 13:39:40 -050043
44inherit autotools ptest pkgconfig useradd python3-dir manpages systemd
45
46SYSTEMD_SERVICE_${PN} = "lttng-sessiond.service"
47SYSTEMD_AUTO_ENABLE = "disable"
48
49USERADD_PACKAGES = "${PN}"
50GROUPADD_PARAM_${PN} = "tracing"
51
52FILES_${PN} += "${libdir}/lttng/libexec/* ${datadir}/xml/lttng \
53 ${PYTHON_SITEPACKAGES_DIR}/*"
54FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
55FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/*.la"
56
57# Since files are installed into ${libdir}/lttng/libexec we match
58# the libexec insane test so skip it.
59# Python module needs to keep _lttng.so
60INSANE_SKIP_${PN} = "libexec dev-so"
61INSANE_SKIP_${PN}-dbg = "libexec"
62
63PRIVATE_LIBS_${PN}-ptest = "libfoo.so"
64
65do_install_append () {
66 # install systemd unit file
67 install -d ${D}${systemd_unitdir}/system
68 install -m 0644 ${WORKDIR}/lttng-sessiond.service ${D}${systemd_unitdir}/system
69}
70
71do_install_ptest () {
Andrew Geisslerc926e172021-05-07 16:11:35 -050072 for f in Makefile tests/Makefile tests/utils/utils.sh tests/regression/tools/save-load/*.lttng tests/regression/tools/save-load/configuration/load-42*.lttng tests/regression/tools/health/test_health.sh tests/regression/tools/metadata/utils.sh tests/regression/tools/rotation/rotate_utils.sh; do
Andrew Geissler82c905d2020-04-13 13:39:40 -050073 install -D "${B}/$f" "${D}${PTEST_PATH}/$f"
74 done
75
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050076 for f in config/tap-driver.sh config/test-driver src/common/config/session.xsd src/common/mi-lttng-4.0.xsd; do
Andrew Geissler82c905d2020-04-13 13:39:40 -050077 install -D "${S}/$f" "${D}${PTEST_PATH}/$f"
78 done
79
80 # Prevent 'make check' from recursing into non-test subdirectories.
81 sed -i -e 's!^SUBDIRS = .*!SUBDIRS = tests!' "${D}${PTEST_PATH}/Makefile"
82
83 # We don't need these
84 sed -i -e '/dist_noinst_SCRIPTS = /,/^$/d' "${D}${PTEST_PATH}/tests/Makefile"
85
86 # We shouldn't need to build anything in tests/utils
87 sed -i -e 's!am__append_1 = . utils!am__append_1 = . !' \
88 "${D}${PTEST_PATH}/tests/Makefile"
89
90 # Copy the tests directory tree and the executables and
91 # Makefiles found within.
92 for d in $(find "${B}/tests" -type d -not -name .libs -printf '%P ') ; do
93 install -d "${D}${PTEST_PATH}/tests/$d"
94 find "${B}/tests/$d" -maxdepth 1 -executable -type f \
95 -exec install -t "${D}${PTEST_PATH}/tests/$d" {} +
96 # Take all .py scripts for tests using the python bindings.
97 find "${B}/tests/$d" -maxdepth 1 -type f -name "*.py" \
98 -exec install -t "${D}${PTEST_PATH}/tests/$d" {} +
99 test -r "${B}/tests/$d/Makefile" && \
100 install -t "${D}${PTEST_PATH}/tests/$d" "${B}/tests/$d/Makefile"
101 done
102
103 for d in $(find "${B}/tests" -type d -name .libs -printf '%P ') ; do
104 for f in $(find "${B}/tests/$d" -maxdepth 1 -executable -type f -printf '%P ') ; do
105 cp ${B}/tests/$d/$f ${D}${PTEST_PATH}/tests/`dirname $d`/$f
106 case $f in
107 *.so)
108 install -d ${D}${PTEST_PATH}/tests/$d/
109 ln -s ../$f ${D}${PTEST_PATH}/tests/$d/$f
110 # Remove any rpath/runpath to pass QA check.
111 chrpath --delete ${D}${PTEST_PATH}/tests/$d/$f
112 ;;
113 esac
114 done
115 done
116
117 chrpath --delete ${D}${PTEST_PATH}/tests/utils/testapp/userspace-probe-elf-binary/userspace-probe-elf-binary
Andrew Geissler90fd73c2021-03-05 15:25:55 -0600118 chrpath --delete ${D}${PTEST_PATH}/tests/regression/ust/ust-dl/libbar.so
119 chrpath --delete ${D}${PTEST_PATH}/tests/regression/ust/ust-dl/libfoo.so
Andrew Geissler82c905d2020-04-13 13:39:40 -0500120
121 #
122 # Use the versioned libs of liblttng-ust-dl.
123 #
124 ustdl="${D}${PTEST_PATH}/tests/regression/ust/ust-dl/test_ust-dl.py"
125 if [ -e $ustdl ]; then
126 sed -i -e 's!:liblttng-ust-dl.so!:liblttng-ust-dl.so.0!' $ustdl
127 fi
128
129 install ${B}/tests/unit/ini_config/sample.ini ${D}${PTEST_PATH}/tests/unit/ini_config/
130
131 # We shouldn't need to build anything in tests/regression/tools
132 sed -i -e 's!^SUBDIRS = tools !SUBDIRS = !' \
133 "${D}${PTEST_PATH}/tests/regression/Makefile"
134
135 # Prevent attempts to update Makefiles during test runs, and
136 # silence "Making check in $SUBDIR" messages.
137 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
138 sed -i -e '/Makefile:/,/^$/d' -e '/%: %.in/,/^$/d' \
139 -e '/echo "Making $$target in $$subdir"; \\/d' \
140 -e 's/^srcdir = \(.*\)/srcdir = ./' \
141 -e 's/^builddir = \(.*\)/builddir = ./' \
142 -e 's/^all-am:.*/all-am:/' \
143 {} +
144
145 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
146 touch -r "${B}/Makefile" {} +
147
148 #
149 # Need to stop generated binaries from rebuilding by removing their source dependencies
150 #
151 sed -e 's#\(^test.*OBJECTS.=\)#disable\1#g' \
152 -e 's#\(^test.*DEPENDENCIES.=\)#disable\1#g' \
153 -e 's#\(^test.*SOURCES.=\)#disable\1#g' \
154 -e 's#\(^test.*LDADD.=\)#disable\1#g' \
155 -i ${D}${PTEST_PATH}/tests/unit/Makefile
156
Andrew Geissler90fd73c2021-03-05 15:25:55 -0600157 # Fix hardcoded build path
Andrew Geisslerc926e172021-05-07 16:11:35 -0500158 sed -e 's#TESTAPP_PATH=.*/tests/regression/#TESTAPP_PATH="${PTEST_PATH}/tests/regression/#' \
Andrew Geissler90fd73c2021-03-05 15:25:55 -0600159 -i ${D}${PTEST_PATH}/tests/regression/ust/python-logging/test_python_logging
160
Andrew Geissler82c905d2020-04-13 13:39:40 -0500161 # Substitute links to installed binaries.
162 for prog in lttng lttng-relayd lttng-sessiond lttng-consumerd lttng-crash; do
163 exedir="${D}${PTEST_PATH}/src/bin/${prog}"
164 install -d "$exedir"
165 case "$prog" in
166 lttng-consumerd)
167 ln -s "${libdir}/lttng/libexec/$prog" "$exedir"
168 ;;
169 *)
170 ln -s "${bindir}/$prog" "$exedir"
171 ;;
172 esac
173 done
174}