blob: 3d12ea09e88923f5656b5414687324fd8805d4de [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "IPC library used by GnuPG and GPGME"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "A small library implementing the so-called Assuan protocol. \
3This protocol is used for IPC between most newer GnuPG components. \
4Both, server and client side functions are provided. "
Brad Bishop19323692019-04-05 15:28:33 -04005HOMEPAGE = "http://www.gnupg.org/related_software/libassuan/"
6BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
7
8LICENSE = "GPLv3+ & LGPLv2.1+"
9LICENSE_${PN} = "LGPLv2.1+"
10LICENSE_${PN}-doc = "GPLv3+"
11LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
12 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
13 file://src/assuan.c;endline=20;md5=ab92143a5a2adabd06d7994d1467ea5c\
14 file://src/assuan-defs.h;endline=20;md5=15d950c83e82978e35b35e790d7e4d39"
15
16DEPENDS = "libgpg-error"
17
18UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
19SRC_URI = "${GNUPG_MIRROR}/libassuan/libassuan-${PV}.tar.bz2 \
20 file://libassuan-add-pkgconfig-support.patch \
21 "
22
Andrew Geisslerc926e172021-05-07 16:11:35 -050023SRC_URI[sha256sum] = "8e8c2fcc982f9ca67dcbb1d95e2dc746b1739a4668bc20b3a3c5be632edb34e4"
Brad Bishop19323692019-04-05 15:28:33 -040024
25BINCONFIG = "${bindir}/libassuan-config"
26
Andrew Geissler82c905d2020-04-13 13:39:40 -050027inherit autotools texinfo binconfig-disabled pkgconfig multilib_header
Brad Bishop19323692019-04-05 15:28:33 -040028
29do_configure_prepend () {
30 # Else these could be used in preference to those in aclocal-copy
31 rm -f ${S}/m4/*.m4
32}
33
Andrew Geissler82c905d2020-04-13 13:39:40 -050034do_install_append () {
35 oe_multilib_header assuan.h
36}
37
Brad Bishop19323692019-04-05 15:28:33 -040038BBCLASSEXTEND = "native nativesdk"