blob: 8e39974ef3f06f92ad9d0a153bf4cbc2040fbbd3 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Hardware RNG based on CPU timing jitter"
2DESCRIPTION = "The Jitter RNG provides a noise source using the CPU execution timing jitter. \
3It does not depend on any system resource other than a high-resolution time \
4stamp. It is a small-scale, yet fast entropy source that is viable in almost \
5all environments and on a lot of CPU architectures."
6HOMEPAGE = "http://www.chronox.de/jent.html"
7LICENSE = "GPLv2+ | BSD"
Andrew Geisslerd1e89492021-02-12 15:35:20 -06008LIC_FILES_CHKSUM = "file://COPYING;md5=c69090e97c8fd6372d03099c0a5bc382 \
Andrew Geissler82c905d2020-04-13 13:39:40 -05009 file://COPYING.gplv2;md5=eb723b61539feef013de476e68b5c50a \
10 file://COPYING.bsd;md5=66a5cedaf62c4b2637025f049f9b826f \
11 "
Andrew Geisslerd1e89492021-02-12 15:35:20 -060012SRC_URI = "git://github.com/smuellerDD/jitterentropy-library.git"
Andrew Geisslerc926e172021-05-07 16:11:35 -050013SRCREV = "a0c51e21c2d4322681a320a22de5e2ef13c08196"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014S = "${WORKDIR}/git"
15
16do_configure[noexec] = "1"
17
18LDFLAGS += "-Wl,-O0"
19
20do_install () {
21 oe_runmake install INCDIR="/include" \
22 DESTDIR="${D}" \
23 PREFIX="${exec_prefix}" \
24 LIBDIR="${baselib}" \
25 INSTALL_STRIP="install"
26}
27