blob: aa296c6b9b4c01265fec23e005a8ff2c31fae8e1 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Easy API to create and parse X.509 and CMS related objects"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "A library to make the tasks of working with X.509 certificates, \
3CMS data and related objects more easy. It provides a highlevel interface to \
4the implemented protocols and presents the data in a consistent way. The \
5library does not rely on another cryptographic library but provides \
6hooks for easy integration with Libgcrypt. "
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007HOMEPAGE = "http://www.gnupg.org/related_software/libksba/"
Brad Bishop64c979e2019-11-04 13:55:29 -05008LICENSE = "GPLv3+ & (GPLv2+ | LGPLv3+)"
9LICENSE_${PN} = "GPLv2+ | LGPLv3+"
10LICENSE_${PN}-doc = "GPLv3+"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011LIC_FILES_CHKSUM = "file://COPYING;md5=fd541d83f75d038c4e0617b672ed8bda \
12 file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
13 file://COPYING.GPLv3;md5=2f31b266d3440dd7ee50f92cf67d8e6c \
14 file://COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
15 "
16
17DEPENDS = "libgpg-error"
18
19BINCONFIG = "${bindir}/ksba-config"
20
21inherit autotools binconfig-disabled pkgconfig texinfo
22
23UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
24SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
25 file://ksba-add-pkgconfig-support.patch"
26
Andrew Geisslerc926e172021-05-07 16:11:35 -050027SRC_URI[sha256sum] = "b0f4c65e4e447d9a2349f6b8c0e77a28be9531e4548ba02c545d1f46dc7bf921"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028
29do_configure_prepend () {
30 # Else these could be used in preference to those in aclocal-copy
31 rm -f ${S}/m4/gpg-error.m4
32}
Brad Bishop316dfdd2018-06-25 12:45:53 -040033
Brad Bishop1d80a2e2019-11-15 16:35:03 -050034BBCLASSEXTEND = "native nativesdk"