blob: 8fe1023901c3940008a25a618c5bdd08bf3f782b [file] [log] [blame]
Andrew Geisslerc926e172021-05-07 16:11:35 -05001SUMMARY = "interface to seccomp filtering mechanism"
2DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
3HOMEPAGE = "https://github.com/seccomp/libseccomp"
4SECTION = "security"
5LICENSE = "LGPL-2.1"
6LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f"
7
8DEPENDS += "gperf-native"
9
10SRCREV = "4bf70431a339a2886ab8c82e9a45378f30c6e6c7"
11
12SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.5 \
13 file://run-ptest \
14 "
15
16COMPATIBLE_HOST_riscv32 = "null"
17
18S = "${WORKDIR}/git"
19
20inherit autotools-brokensep pkgconfig ptest features_check
21
22REQUIRED_DISTRO_FEATURES = "seccomp"
23
24PACKAGECONFIG ??= ""
25PACKAGECONFIG[python] = "--enable-python, --disable-python, python3"
26
27DISABLE_STATIC = ""
28
29do_compile_ptest() {
30 oe_runmake -C tests check-build
31}
32
33do_install_ptest() {
34 install -d ${D}${PTEST_PATH}/tests
35 install -d ${D}${PTEST_PATH}/tools
36 for file in $(find tests/* -executable -type f); do
37 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
38 done
39 for file in $(find tests/*.tests -type f); do
40 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
41 done
42 for file in $(find tools/* -executable -type f); do
43 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
44 done
45 # Overwrite libtool wrappers with real executables
46 for file in $(find tools/.libs/* -executable -type f); do
47 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
48 done
49}
50
51FILES_${PN} = "${bindir} ${libdir}/${BPN}.so*"
52FILES_${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
53
54RDEPENDS_${PN}-ptest = "coreutils bash"