blob: 3905ef7dbc697760633e6f4d0c297b58b333b074 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Extremely Fast Compression algorithm"
2DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems."
Andrew Geissler95ac1b82021-03-31 14:34:31 -05003HOMEPAGE = "https://github.com/lz4/lz4"
Brad Bishopc342db32019-05-15 21:57:59 -04004
5LICENSE = "BSD | BSD-2-Clause | GPL-2.0"
6LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=ebc2ea4814a64de7708f1571904b32cc \
7 file://programs/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://LICENSE;md5=d57c0d21cb917fb4e0af2454aa48b956 \
9 "
10
11PE = "1"
12
Andrew Geissler09209ee2020-12-13 08:44:15 -060013SRCREV = "d44371841a2f1728a3f36839fd4b7e872d0927d3"
Brad Bishopc342db32019-05-15 21:57:59 -040014
Andrew Geissler09209ee2020-12-13 08:44:15 -060015SRC_URI = "git://github.com/lz4/lz4.git;branch=release \
Brad Bishopc342db32019-05-15 21:57:59 -040016 file://run-ptest \
17 "
18UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
19
20S = "${WORKDIR}/git"
21
Brad Bishop1d80a2e2019-11-15 16:35:03 -050022# Fixed in r118, which is larger than the current version.
23CVE_CHECK_WHITELIST += "CVE-2014-4715"
24
Andrew Geisslerc926e172021-05-07 16:11:35 -050025EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' CFLAGS='${CFLAGS}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir} BUILD_STATIC=no"
Brad Bishopc342db32019-05-15 21:57:59 -040026
27do_install() {
28 oe_runmake install
29}
30
31BBCLASSEXTEND = "native nativesdk"