blob: ac650a4a8b736c819d07922133c9249227125cbd [file] [log] [blame]
Jayanth Othayothc9385132021-06-21 07:21:14 -05001HOMEPAGE = "https://github.com/open-power/libekb_p10"
2
3SUMMARY = "Hardware Procedure Framework"
4DESCRIPTION = "Provides infrastructure to run hardware procedures"
5PR = "r1"
6PV = "1.0+git${SRCPV}"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
9
10S = "${WORKDIR}/git"
11
12require recipes-bsp/ekb/ekb.inc
13
14inherit autotools \
15 python3native \
16 perlnative
17
18SRCREV_FORMAT = "libekb_ekb"
19
20SRCREV_libekb = "a68c2f610243d3f128f561c4451135241aedbf6b"
21SRCREV_ekb = "${EKB_REV}"
22
23SRC_URI = "git://git@github.com/open-power/libekb_p10;branch="main";name=libekb \
24 ${EKB_URI};name=ekb;destsuffix=git/ekb \
25 "
26
27DEPENDS = "pdbg libxml-simple-perl-native"