blob: 97ca66d66f0e3a3993dc9cce1a66e025efd8c83a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "nl80211 based CLI configuration utility for wireless devices"
2DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \
3wireless devices. It supports almost all new drivers that have been added \
4to the kernel recently. "
5HOMEPAGE = "http://wireless.kernel.org/en/users/Documentation/iw"
6SECTION = "base"
7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
9
10DEPENDS = "libnl"
11
12SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.gz \
13 file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \
14 file://separate-objdir.patch \
15"
16
Andrew Geisslerc9f78652020-09-18 14:11:35 -050017SRC_URI[md5sum] = "98129d64212bdbb408f009c56ed5c62a"
18SRC_URI[sha256sum] = "cd9125c7e560926d66b09977fe0f75e5365ffd05a15df67d86a421dc76f96a96"
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20inherit pkgconfig
21
22EXTRA_OEMAKE = "\
23 -f '${S}/Makefile' \
24 \
25 'PREFIX=${prefix}' \
26 'SBINDIR=${sbindir}' \
27 'MANDIR=${mandir}' \
28"
29
30do_install() {
31 oe_runmake 'DESTDIR=${D}' install
32}