blob: 7a4dcbec57b2ff54f830cc34d11600edec63db0c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Minimal gettext for supporting native autoconf/automake"
2DESCRIPTION = "Contains the m4 macros sufficient to support building \
3autoconf/automake. This provides a significant build time speedup by \
4the removal of gettext-native from most dependency chains (now only \
5needed for gettext for the target)."
6SRC_URI = "file://aclocal/ \
7 file://config.rpath \
8 file://Makefile.in.in \
9 file://remove-potcdate.sin \
10 file://COPYING \
11"
12
13INHIBIT_DEFAULT_DEPS = "1"
14INHIBIT_AUTOTOOLS_DEPS = "1"
15
16LICENSE = "FSF-Unlimited"
17LIC_FILES_CHKSUM = "file://COPYING;md5=4bd090a20bfcd1a18f1f79837b5e3e91"
18
19inherit native
20
21S = "${WORKDIR}"
22
23do_install () {
24 install -d ${D}${datadir}/aclocal/
25 cp ${WORKDIR}/aclocal/*.m4 ${D}${datadir}/aclocal/
26 install -d ${D}${datadir}/gettext/po/
27 cp ${WORKDIR}/config.rpath ${D}${datadir}/gettext/
28 cp ${WORKDIR}/Makefile.in.in ${D}${datadir}/gettext/po/
29 cp ${WORKDIR}/remove-potcdate.sin ${D}${datadir}/gettext/po/
30}