blob: 0df681ac7385e669bf744b118cdb7fde32861b3e [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Extensible SDK toolchain meta-recipe"
2DESCRIPTION = "Meta-recipe for ensuring the build directory contains all appropriate toolchain packages for using an IDE"
3LICENSE = "MIT"
Patrick Williamsc0f7c042017-02-23 20:41:17 -06004
5DEPENDS = "virtual/libc gdb-cross-${TARGET_ARCH} qemu-native qemu-helper-native unfs3-native"
6
7do_populate_sysroot[deptask] = "do_populate_sysroot"
8
9# NOTE: There is logic specific to this recipe in setscene_depvalid()
10# within sstate.bbclass, so if you copy or rename this and expect the same
11# functionality you'll need to modify that as well.
12
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013LOCKED_SIGS_INDIR = "${WORKDIR}/locked-sigs"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060014
15addtask do_locked_sigs after do_populate_sysroot
16SSTATETASKS += "do_locked_sigs"
17do_locked_sigs[sstate-inputdirs] = "${LOCKED_SIGS_INDIR}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018do_locked_sigs[sstate-outputdirs] = "${STAGING_DIR}/${PACKAGE_ARCH}/${PN}/locked-sigs"
Andrew Geissler82c905d2020-04-13 13:39:40 -050019# If a taskhash changes we need to use the latest hash changes. With unihash we may not rebuild.
20# eSDK which uses this is nostamp anyway
21do_locked_sigs[nostamp] = "1"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060022
23python do_locked_sigs() {
24 import oe.copy_buildsystem
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025 outdir = os.path.join(d.getVar('LOCKED_SIGS_INDIR'))
Patrick Williamsc0f7c042017-02-23 20:41:17 -060026 bb.utils.mkdirhier(outdir)
27 sigfile = os.path.join(outdir, 'locked-sigs-extsdk-toolchain.inc')
28 oe.copy_buildsystem.generate_locked_sigs(sigfile, d)
29}