blob: 61e46a4ed7b85b1a8445ab4380a89d31aaadc784 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Utilities and libraries for handling compiled object files"
2HOMEPAGE = "https://sourceware.org/elfutils"
3SECTION = "base"
4LICENSE = "GPLv2 & LGPLv3+ & GPLv3+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6DEPENDS = "zlib virtual/libintl"
7DEPENDS_append_libc-musl = " argp-standalone fts musl-obstack "
8# The Debian patches below are from:
9# http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.176-1.debian.tar.xz
10SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2 \
11 file://0001-dso-link-change.patch \
12 file://0002-Fix-elf_cvt_gunhash-if-dest-and-src-are-same.patch \
13 file://0003-fixheadercheck.patch \
14 file://0004-Disable-the-test-to-convert-euc-jp.patch \
15 file://0006-Fix-build-on-aarch64-musl.patch \
16 file://0001-libasm-may-link-with-libbz2-if-found.patch \
17 file://0001-libelf-elf_end.c-check-data_list.data.d.d_buf-before.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050018 file://0001-skip-the-test-when-gcc-not-deployed.patch \
19 file://0001-ppc_initreg.c-Incliude-asm-ptrace.h-for-pt_regs-defi.patch \
20 file://run-ptest \
21 file://ptest.patch \
Andrew Geissler475cb722020-07-10 16:00:51 -050022 file://0001-tests-Makefile.am-compile-test_nlist-with-standard-C.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050023 "
24SRC_URI_append_libc-musl = " \
25 file://0001-musl-obstack-fts.patch \
26 file://0002-musl-libs.patch \
27 file://0003-musl-utils.patch \
28 file://0004-Fix-error-on-musl.patch \
Andrew Geissler475cb722020-07-10 16:00:51 -050029 file://0015-config-eu.am-do-not-use-Werror.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050030 "
Andrew Geissler475cb722020-07-10 16:00:51 -050031SRC_URI[sha256sum] = "b827b6e35c59d188ba97d7cf148fa8dc6f5c68eb6c5981888dfdbb758c0b569d"
Andrew Geissler82c905d2020-04-13 13:39:40 -050032
33inherit autotools gettext ptest pkgconfig
34
35EXTRA_OECONF = "--program-prefix=eu- --disable-debuginfod"
36
37DEPENDS_BZIP2 = "bzip2-replacement-native"
38DEPENDS_BZIP2_class-target = "bzip2"
39
40PACKAGECONFIG ??= ""
41PACKAGECONFIG[bzip2] = "--with-bzlib,--without-bzlib,${DEPENDS_BZIP2}"
42PACKAGECONFIG[xz] = "--with-lzma,--without-lzma,xz"
43
44RDEPENDS_${PN}-ptest += "libasm libelf bash make coreutils ${PN}-binutils"
45
46EXTRA_OECONF_append_class-target = " --disable-tests-rpath"
47
48RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
49
50do_compile_ptest() {
51 cd ${B}/tests
52 oe_runmake buildtest-TESTS oecheck
53}
54
55do_install_ptest() {
56 if [ ${PTEST_ENABLED} = "1" ]; then
57 # copy the files which needed by the cases
58 TEST_FILES="strip strip.o addr2line elfcmp objdump readelf size.o nm.o nm elflint elfcompress elfclassify stack unstrip"
59 install -d -m 755 ${D}${PTEST_PATH}/src
60 install -d -m 755 ${D}${PTEST_PATH}/libelf
61 install -d -m 755 ${D}${PTEST_PATH}/libdw
62 install -d -m 755 ${D}${PTEST_PATH}/libasm
63 for test_file in ${TEST_FILES}; do
64 if [ -f ${B}/src/${test_file} ]; then
65 cp -r ${B}/src/${test_file} ${D}${PTEST_PATH}/src
66 fi
67 done
68 cp ${D}${libdir}/libelf-${PV}.so ${D}${PTEST_PATH}/libelf/libelf.so
69 cp ${D}${libdir}/libdw-${PV}.so ${D}${PTEST_PATH}/libdw/libdw.so
70 cp ${D}${libdir}/libasm-${PV}.so ${D}${PTEST_PATH}/libasm/libasm.so
71 cp -r ${S}/tests/ ${D}${PTEST_PATH}
72 cp -r ${B}/tests/* ${D}${PTEST_PATH}/tests
73 cp -r ${B}/config.h ${D}${PTEST_PATH}
74 cp -r ${B}/backends ${D}${PTEST_PATH}
75 sed -i '/^Makefile:/c Makefile:' ${D}${PTEST_PATH}/tests/Makefile
76 find ${D}${PTEST_PATH} -type f -name *.[hoc] | xargs -i rm {}
77 fi
78}
79
80EXTRA_OEMAKE_class-native = ""
81EXTRA_OEMAKE_class-nativesdk = ""
82
83BBCLASSEXTEND = "native nativesdk"
84
85# Package utilities separately
86PACKAGES =+ "${PN}-binutils libelf libasm libdw"
87
88# shared libraries are licensed GPLv2 or GPLv3+, binaries GPLv3+
89# according to NEWS file:
90# "The license is now GPLv2/LGPLv3+ for the libraries and GPLv3+ for stand-alone
91# programs. There is now also a formal CONTRIBUTING document describing how to
92# submit patches."
93LICENSE_${PN}-binutils = "GPLv3+"
94LICENSE_${PN} = "GPLv3+"
95LICENSE_libelf = "GPLv2 | LGPLv3+"
96LICENSE_libasm = "GPLv2 | LGPLv3+"
97LICENSE_libdw = "GPLv2 | LGPLv3+"
98
99FILES_${PN}-binutils = "\
100 ${bindir}/eu-addr2line \
101 ${bindir}/eu-ld \
102 ${bindir}/eu-nm \
103 ${bindir}/eu-readelf \
104 ${bindir}/eu-size \
105 ${bindir}/eu-strip"
106
107FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*"
108FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*"
109FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*"
110# Some packages have the version preceeding the .so instead properly
111# versioned .so.<version>, so we need to reorder and repackage.
112#FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so"
113#FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so"
114
115# The package contains symlinks that trip up insane
116INSANE_SKIP_${MLPREFIX}libdw = "dev-so"
Andrew Geisslerc9f78652020-09-18 14:11:35 -0500117# The nlist binary in the tests uses explicitly minimal compiler flags
118INSANE_SKIP_${PN}-ptest += "ldflags"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500119
120# avoid stripping some generated binaries otherwise some of the tests such as test-nlist,
121# run-strip-reloc.sh, run-strip-strmerge.sh and so on will fail
122INHIBIT_PACKAGE_STRIP_FILES = "\
123 ${PKGD}${PTEST_PATH}/tests/test-nlist \
124 ${PKGD}${PTEST_PATH}/tests/elfstrmerge \
125 ${PKGD}${PTEST_PATH}/tests/backtrace-child \
126 ${PKGD}${PTEST_PATH}/tests/backtrace-data \
127 ${PKGD}${PTEST_PATH}/tests/backtrace-dwarf \
128 ${PKGD}${PTEST_PATH}/tests/deleted \
129 ${PKGD}${PTEST_PATH}/src/strip \
130 ${PKGD}${PTEST_PATH}/src/addr2line \
131 ${PKGD}${PTEST_PATH}/src/elfcmp \
132 ${PKGD}${PTEST_PATH}/src/objdump \
133 ${PKGD}${PTEST_PATH}/src/readelf \
134 ${PKGD}${PTEST_PATH}/src/nm \
135 ${PKGD}${PTEST_PATH}/src/elflint \
136 ${PKGD}${PTEST_PATH}/src/elfclassify \
137 ${PKGD}${PTEST_PATH}/src/stack \
138 ${PKGD}${PTEST_PATH}/src/unstrip \
139 ${PKGD}${PTEST_PATH}/libelf/libelf.so \
140 ${PKGD}${PTEST_PATH}/libdw/libdw.so \
141 ${PKGD}${PTEST_PATH}/libasm/libasm.so \
142 ${PKGD}${PTEST_PATH}/backends/libebl_i386.so \
143 ${PKGD}${PTEST_PATH}/backends/libebl_x86_64.so \
144"
145
146PRIVATE_LIBS_${PN}-ptest = "libdw.so.1 libelf.so.1 libasm.so.1"