blob: 4bf9dd50b2c35f9d8823cc3a109f0284ab58005d [file] [log] [blame]
Andrew Geisslerc9f78652020-09-18 14:11:35 -05001require go-${PV}.inc
2require go-target.inc
3
4inherit linuxloader
5
6export GOBUILDMODE=""
7export CGO_ENABLED_riscv64 = ""
8export GO_LDSO = "${@get_linuxloader(d)}"
9
10# mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv and its
11# variants.
12python() {
13 if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv' in d.getVar('TARGET_ARCH',True):
14 d.appendVar('INSANE_SKIP_%s' % d.getVar('PN',True), " textrel")
15}