blob: eefac4166aea405d9787cc84b13e75bdd4229b1c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Ninja is a small build system with a focus on speed."
2HOMEPAGE = "http://martine.github.com/ninja/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
5
6DEPENDS = "re2c-native ninja-native"
7
Andrew Geisslerc9f78652020-09-18 14:11:35 -05008SRCREV = "a1f879b29c9aafe6a2bc0ba885701f8f4f19f772"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release"
11UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
12
13S = "${WORKDIR}/git"
14
15do_configure[noexec] = "1"
16
17do_compile_class-native() {
18 python3 ./configure.py --bootstrap
19}
20
21do_compile() {
22 python3 ./configure.py
23 ninja
24}
25
26do_install() {
27 install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja
28}
29
30BBCLASSEXTEND = "native nativesdk"