Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Universal Addresses to RPC Program Number Mapper" |
| 2 | DESCRIPTION = "The rpcbind utility is a server that converts RPC \ |
| 3 | program numbers into universal addresses." |
| 4 | SECTION = "console/network" |
| 5 | HOMEPAGE = "http://sourceforge.net/projects/rpcbind/" |
| 6 | BUGTRACKER = "http://sourceforge.net/tracker/?group_id=201237&atid=976751" |
| 7 | DEPENDS = "libtirpc quota" |
| 8 | |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 9 | LICENSE = "BSD-3-Clause" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=b46486e4c4a416602693a711bb5bfa39 \ |
| 11 | file://src/rpcinfo.c;beginline=1;endline=27;md5=f8a8cd2cb25ac5aa16767364fb0e3c24" |
| 12 | |
| 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/rpcbind/rpcbind-${PV}.tar.bz2 \ |
| 14 | file://init.d \ |
| 15 | file://rpcbind.conf \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 16 | file://rpcbind_add_option_to_fix_port_number.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | file://0001-systemd-use-EnvironmentFile.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | " |
| 19 | SRC_URI[md5sum] = "ed46f09b9c0fa2d49015f6431bc5ea7b" |
| 20 | SRC_URI[sha256sum] = "2ce360683963b35c19c43f0ee2c7f18aa5b81ef41c3fdbd15ffcb00b8bffda7a" |
| 21 | |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame^] | 22 | inherit autotools update-rc.d systemd pkgconfig update-alternatives |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 23 | |
| 24 | PACKAGECONFIG ??= "tcp-wrappers" |
| 25 | PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers" |
| 26 | |
| 27 | INITSCRIPT_NAME = "rpcbind" |
| 28 | INITSCRIPT_PARAMS = "start 12 2 3 4 5 . stop 60 0 1 6 ." |
| 29 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 30 | SYSTEMD_SERVICE_${PN} = "rpcbind.service rpcbind.socket" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 31 | |
| 32 | inherit useradd |
| 33 | |
| 34 | USERADD_PACKAGES = "${PN}" |
| 35 | USERADD_PARAM_${PN} = "--system --no-create-home --home-dir / \ |
| 36 | --shell /bin/false --user-group rpc" |
| 37 | |
| 38 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 39 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/, \ |
| 40 | --without-systemdsystemunitdir, \ |
| 41 | systemd \ |
| 42 | " |
| 43 | |
| 44 | EXTRA_OECONF += " --enable-warmstarts --with-rpcuser=rpc" |
| 45 | |
| 46 | do_install_append () { |
| 47 | install -d ${D}${sysconfdir}/init.d |
| 48 | sed -e 's,/etc/,${sysconfdir}/,g' \ |
| 49 | -e 's,/sbin/,${sbindir}/,g' \ |
| 50 | ${WORKDIR}/init.d > ${D}${sysconfdir}/init.d/rpcbind |
| 51 | chmod 0755 ${D}${sysconfdir}/init.d/rpcbind |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 52 | } |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame^] | 53 | |
| 54 | ALTERNATIVE_${PN} = "rpcinfo" |
| 55 | ALTERNATIVE_LINK_NAME[rpcinfo] = "${bindir}/rpcinfo" |