blob: 00be3aac27c85550ea9063da7237afee71a426e8 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Wayland, a protocol between a compositor and clients"
2DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3as well as a C library implementation of that protocol. The compositor can be \
4a standalone display server running on Linux kernel modesetting and evdev \
5input devices, an X application, or a wayland client itself. The clients can \
6be traditional applications, X servers (rootless or fullscreen) or other \
7display servers."
8HOMEPAGE = "http://wayland.freedesktop.org"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
11 file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
12
13DEPENDS = "expat libffi wayland-native"
14
15SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
16 file://run-ptest \
17 file://0002-meson.build-find-the-native-wayland-scanner-directly.patch \
18 file://0002-Do-not-hardcode-the-path-to-wayland-scanner.patch \
19 file://0001-build-Fix-strndup-detection-on-MinGW.patch \
20 file://0001-meson-tests-add-missing-dependencies-on-protocol-hea.patch \
21 "
22SRC_URI[md5sum] = "23317697b6e3ff2e1ac8c5ba3ed57b65"
23SRC_URI[sha256sum] = "4675a79f091020817a98fd0484e7208c8762242266967f55a67776936c2e294d"
24
25UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
26
27inherit meson pkgconfig ptest
28
29PACKAGECONFIG ??= "dtd-validation"
30PACKAGECONFIG[dtd-validation] = "-Ddtd_validation=true,-Ddtd_validation=false,libxml2,,"
31
32EXTRA_OEMESON = "-Ddocumentation=false"
33EXTRA_OEMESON_class-native = "-Ddocumentation=false -Dlibraries=false"
34
35# Wayland installs a M4 macro for other projects to use, which uses the target
36# pkg-config to find files. Replace pkg-config with pkg-config-native.
37do_install_append_class-native() {
38 sed -e 's,PKG_CHECK_MODULES(.*),,g' \
39 -e 's,$PKG_CONFIG,pkg-config-native,g' \
40 -i ${D}/${datadir}/aclocal/wayland-scanner.m4
41}
42
43do_install_ptest() {
44 mkdir -p ${D}${PTEST_PATH}/tests/data
45 cp -rf ${B}/tests/*-test ${B}/tests/*-checker ${D}${PTEST_PATH}/tests
46 cp -rf ${B}/tests/*-checker ${D}${PTEST_PATH}
47 cp -rf ${S}/tests/scanner-test.sh ${D}${PTEST_PATH}/tests
48 cp -rf ${S}/tests/data/* ${D}${PTEST_PATH}/tests/data/
49 cp -rf ${S}/egl/wayland-egl-symbols-check ${D}${PTEST_PATH}/tests/
50}
51
52sysroot_stage_all_append_class-target () {
53 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
54 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
55}
56
57FILES_${PN} = "${libdir}/*${SOLIBS}"
58FILES_${PN}-dev += "${bindir} ${datadir}/wayland"
59
60BBCLASSEXTEND = "native nativesdk"
61
62RDEPENDS_${PN}-ptest += "binutils sed"