blob: 2b1f513f1c7e08744f36bd9693b10487d100343b [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Ultra-simple screen capture utility, aimed at handheld devices"
2HOMEPAGE = "http://www.o-hand.com"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://main.c;endline=9;md5=023e14d6404d0a961eb97cbd011fc141 \
8 file://screenshot-ui.h;endline=9;md5=638d9ffa83e9325a36df224166ed6ad0"
9
10DEPENDS = "matchbox-panel-2 gtk+3"
11
12# SRCREV tagged 0.3
13SRCREV = "9250fa5a012d84ff45984e8c4345ee7635227756"
14SRC_URI = "git://git.yoctoproject.org/screenshot"
15UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
16
17S = "${WORKDIR}/git"
18
Brad Bishop6dbb3162019-11-25 09:41:34 -050019inherit autotools pkgconfig features_check
Patrick Williamsc0f7c042017-02-23 20:41:17 -060020
21FILES_${PN} += "${libdir}/matchbox-panel/*.so"
22
23do_install_append () {
Andrew Geisslerc9f78652020-09-18 14:11:35 -050024 rm -f ${D}${libdir}/matchbox-panel/*.la
Patrick Williamsc0f7c042017-02-23 20:41:17 -060025}
26
27# The matchbox-panel-2 requires x11 in DISTRO_FEATURES
28REQUIRED_DISTRO_FEATURES = "x11"