blob: 6e6de454940c9b47715c85452db3de1da9b91fb9 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001require libcap-ng.inc
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08002
Brad Bishop15ae2502019-06-18 21:44:24 -04003inherit lib_package autotools
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004
Brad Bishop15ae2502019-06-18 21:44:24 -04005EXTRA_OECONF += "--without-python --without-python3"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006
Brad Bishop15ae2502019-06-18 21:44:24 -04007BBCLASSEXTEND = "native nativesdk"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008
9do_install_append() {
10 # Moving libcap-ng to base_libdir
11 if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
12 mkdir -p ${D}/${base_libdir}/
13 mv -f ${D}${libdir}/libcap-ng.so.* ${D}${base_libdir}/
14 relpath=${@os.path.relpath("${base_libdir}", "${libdir}")}
15 ln -sf ${relpath}/libcap-ng.so.0.0.0 ${D}${libdir}/libcap-ng.so
16 fi
17}