blob: f53056f5c953ac21c9842bab6fb6ffdf60a5e721 [file] [log] [blame]
Andrew Geissler475cb722020-07-10 16:00:51 -05001SUMMARY = "Small library that defines common error values for all GnuPG components"
2HOMEPAGE = "http://www.gnupg.org/related_software/libgpg-error/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4
5LICENSE = "GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
8 file://src/gpg-error.h.in;beginline=2;endline=18;md5=d82591bc81561f617da71e00ff4a9d79 \
9 file://src/init.c;beginline=2;endline=17;md5=f01cdfcf747af5380590cfd9bbfeaaf7 \
10 "
11
12
13SECTION = "libs"
14
15UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
16SRC_URI = "${GNUPG_MIRROR}/libgpg-error/libgpg-error-${PV}.tar.bz2 \
17 file://pkgconfig.patch \
18 file://0001-Do-not-fail-when-testing-config-scripts.patch \
Andrew Geissler475cb722020-07-10 16:00:51 -050019 "
20
Andrew Geisslerc9f78652020-09-18 14:11:35 -050021SRC_URI[sha256sum] = "4a836edcae592094ef1c5a4834908f44986ab2b82e0824a0344b49df8cdb298f"
Andrew Geissler475cb722020-07-10 16:00:51 -050022
23BINCONFIG = "${bindir}/gpg-error-config"
24
25inherit autotools binconfig-disabled pkgconfig gettext multilib_header multilib_script
26
27MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/gpgrt-config"
28
29CPPFLAGS += "-P"
30
31do_install_append() {
32 # we don't have common lisp in OE
33 rm -rf "${D}${datadir}/common-lisp/"
34 oe_multilib_header gpg-error.h gpgrt.h
35}
36
37FILES_${PN}-dev += "${bindir}/gpg-error"
38FILES_${PN}-doc += "${datadir}/libgpg-error/errorref.txt"
39
40BBCLASSEXTEND = "native nativesdk"