blob: b1fd2334b28ce9c63e6a2fc1e627c46f951541cf [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Provides a way to load and enumerate PKCS#11 modules"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50"
4
5inherit meson gettext pkgconfig gtk-doc bash-completion
6
7DEPENDS = "libtasn1 libtasn1-native libffi"
8
9DEPENDS_append = "${@' glib-2.0' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
10
11SRC_URI = "git://github.com/p11-glue/p11-kit"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050012SRCREV = "fd8b56f3ee971f94dc6fc95411fc01e1c12153ab"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013S = "${WORKDIR}/git"
14
15PACKAGECONFIG ??= ""
16PACKAGECONFIG[trust-paths] = "-Dtrust_paths=/etc/ssl/certs/ca-certificates.crt,,,ca-certificates"
17
18GTKDOC_MESON_OPTION = 'gtk_doc'
19
20FILES_${PN} += " \
21 ${libdir}/p11-kit-proxy.so \
22 ${libdir}/pkcs11/*.so \
23 ${libdir}/pkcs11/*.la \
24 ${systemd_user_unitdir}/*"
25
26# PN contains p11-kit-proxy.so, a symlink to a loadable module
27INSANE_SKIP_${PN} = "dev-so"
28
29BBCLASSEXTEND = "nativesdk"