blob: e3c74a516209e9f62d7f5163f180a8cc2795d12a [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Utility for IPMI control"
2DESCRIPTION = "This package contains a utility for interfacing with devices that support \
3the Intelligent Platform Management Interface specification. IPMI is \
4an open standard for machine health, inventory, and remote power control. \
5\
6This utility can communicate with IPMI-enabled devices through either a \
7kernel driver such as OpenIPMI or over the RMCP LAN protocol defined in \
8the IPMI specification. IPMIv2 adds support for encrypted LAN \
9communications and remote Serial-over-LAN functionality. \
10\
11It provides commands for reading the Sensor Data Repository (SDR) and \
12displaying sensor values, displaying the contents of the System Event \
13Log (SEL), printing Field Replaceable Unit (FRU) information, reading and \
14setting LAN configuration, and chassis power control. \
15"
16
17HOMEPAGE = "http://ipmitool.sourceforge.net/"
18SECTION = "kernel/userland"
19
20LICENSE = "BSD-3-Clause"
21LIC_FILES_CHKSUM = "file://COPYING;md5=9aa91e13d644326bf281924212862184"
22
23DEPENDS = "openssl readline ncurses"
24
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025SRC_URI = "${SOURCEFORGE_MIRROR}/ipmitool/ipmitool-${PV}.tar.bz2 \
26 file://0001-Migrate-to-openssl-1.1.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050027 file://0001-fru-Fix-buffer-overflow-vulnerabilities.patch \
28 file://0001-fru-Fix-buffer-overflow-in-ipmi_spd_print_fru.patch \
29 file://0002-session-Fix-buffer-overflow-in-ipmi_get_session_info.patch \
30 file://0003-channel-Fix-buffer-overflow.patch \
31 file://0004-lanp-Fix-buffer-overflows-in-get_lan_param_select.patch \
32 file://0005-fru-sdr-Fix-id_string-buffer-overflows.patch \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050033 file://0001-hpmfwupg-move-variable-definition-to-.c-file.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080034 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035SRC_URI[md5sum] = "bab7ea104c7b85529c3ef65c54427aa3"
36SRC_URI[sha256sum] = "0c1ba3b1555edefb7c32ae8cd6a3e04322056bc087918f07189eeedfc8b81e01"
37
38inherit autotools
39
40# --disable-dependency-tracking speeds up the build
41# --enable-file-security adds some security checks
42# --disable-intf-free disables FreeIPMI support - we don't want to depend on
43# FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility.
44#
45EXTRA_OECONF = "--disable-dependency-tracking --enable-file-security --disable-intf-free"