Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "A sophisticated Numeric Processing Package for Python" |
| 2 | HOMEPAGE = "https://numpy.org/" |
| 3 | DESCRIPTION = "NumPy is the fundamental package needed for scientific computing with Python." |
| 4 | SECTION = "devel/python" |
| 5 | LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF-2.0 & Apache-2.0 & MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8026691468924fb6ec155dadfe2a1a7f" |
| 7 | |
| 8 | SRCNAME = "numpy" |
| 9 | |
| 10 | SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${SRCNAME}-${PV}.tar.gz \ |
| 11 | file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \ |
| 12 | file://0001-numpy-core-Define-RISCV-32-support.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 13 | file://run-ptest \ |
| 14 | " |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "003a9f530e880cb2cd177cba1af7220b9aa42def9c4afc2a2fc3ee6be7eb2b22" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 16 | |
| 17 | GITHUB_BASE_URI = "https://github.com/numpy/numpy/releases" |
| 18 | UPSTREAM_CHECK_REGEX = "releases/tag/v?(?P<pver>\d+(\.\d+)+)$" |
| 19 | |
| 20 | DEPENDS += "python3-cython-native" |
| 21 | |
| 22 | inherit ptest setuptools3 github-releases |
| 23 | |
| 24 | S = "${WORKDIR}/numpy-${PV}" |
| 25 | |
| 26 | CLEANBROKEN = "1" |
| 27 | |
| 28 | do_compile:prepend() { |
| 29 | export NPY_DISABLE_SVML=1 |
| 30 | } |
| 31 | |
| 32 | # Unfortunately the following pyc files are non-deterministc due to 'frozenset' |
| 33 | # being written without strict ordering, even with PYTHONHASHSEED = 0 |
| 34 | # Upstream is discussing ways to solve the issue properly, until then let's |
| 35 | # just not install the problematic files. |
| 36 | # More info: http://benno.id.au/blog/2013/01/15/python-determinism |
| 37 | do_install:append() { |
| 38 | rm ${D}${PYTHON_SITEPACKAGES_DIR}/numpy/typing/tests/data/pass/__pycache__/literal.cpython* |
| 39 | } |
| 40 | |
| 41 | FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a" |
| 42 | |
| 43 | # install what is needed for numpy.test() |
| 44 | RDEPENDS:${PN} = "${PYTHON_PN}-unittest \ |
| 45 | ${PYTHON_PN}-difflib \ |
| 46 | ${PYTHON_PN}-pprint \ |
| 47 | ${PYTHON_PN}-pickle \ |
| 48 | ${PYTHON_PN}-shell \ |
| 49 | ${PYTHON_PN}-doctest \ |
| 50 | ${PYTHON_PN}-datetime \ |
| 51 | ${PYTHON_PN}-distutils \ |
| 52 | ${PYTHON_PN}-misc \ |
| 53 | ${PYTHON_PN}-mmap \ |
| 54 | ${PYTHON_PN}-netclient \ |
| 55 | ${PYTHON_PN}-numbers \ |
| 56 | ${PYTHON_PN}-pydoc \ |
| 57 | ${PYTHON_PN}-pkgutil \ |
| 58 | ${PYTHON_PN}-email \ |
| 59 | ${PYTHON_PN}-compression \ |
| 60 | ${PYTHON_PN}-ctypes \ |
| 61 | ${PYTHON_PN}-threading \ |
| 62 | ${PYTHON_PN}-multiprocessing \ |
| 63 | ${PYTHON_PN}-json \ |
| 64 | " |
| 65 | RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest \ |
| 66 | ${PYTHON_PN}-hypothesis \ |
| 67 | ${PYTHON_PN}-sortedcontainers \ |
| 68 | ${PYTHON_PN}-resource \ |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 69 | ${PYTHON_PN}-typing-extensions \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 70 | ldd \ |
| 71 | " |
| 72 | |
| 73 | BBCLASSEXTEND = "native nativesdk" |